Stuck at 79% updating to Firmware 8.1


Trying to upgrade from the 8.x firmware that came with my Soho mk3 to 8.1 version. All seemed to be going well but it has been stuck on 79% progress for the last 45 minutes.

Can I stop the process without bricking the device?

Sometimes it doesn’t reconnect after upgrade. Can you open another web browser and try to access it?

1 Like

Thanks for the suggestion! I tried it but it did not work.

I took a chance and just powered the unit off/on and hoped for the best.

The unit came back on and the firmware update did occur.

For me 8.1.0 appears to succeed but on reboot 8.0.2 is still in place. Tried manual download (same) - I don’t use InControl. I see web reports that ppl only get this wo work when using InControl.
Need diagnostics? TY

@GLFx, please try the provided firmware below.


I have two SOHO MK3 units that are both having trouble with the firmware upgrade from 8.0.2 to 8.1.0. I have tried to upgrade several times from within the Web admin interface and from InControl. I would prefer to see the automatic update work. Is there a fix coming?


I found the following message in InControl for my two Soho units:
8.0.2s091 build 1507 (Too many firmware update attempts. Update aborted. (Check device’s connectivity to firmware download site. E.g. https : // download dot peplink dot com.) )

When I put that link into Vivaldi, I get:
This site can’t provide a secure connection uses an unsupported protocol.

When I tried Firefox and Opera I get a nearly blank page that only says:
http : // download dot peplink dot com

But works just fine.
What am I doing wrong?
(You might be aware that the editor wouldn’t let me enter more than two links.)