Starting OpenVPN server on hosted FusionHub

I’ve installed FusionHub on my own server and it’s connecting ok with the Peplink.
I’d like to enable OpenVPN so I’ve checked “Enable” in Network/Remote User Access, then I selected “OpenVPN”, checked my WAN interface, and added a user, then “Apply changes”.

However the UDP port 1194 is still closed:

1194/udp closed openvpn

What should I do to activate OpenVPN?

Thanks in advance


So I find this (Fusionhub Solo and Openvpn) and upgraded the firmware. Now the port is opened but the auth is rejected… (even after re-downloading the .ovpn file).

Found this: OpenVPN failing to connect with auth failure - #4 by davenet, which allowed me to make it work.

Add a grouped network
Enable DHCP on a subrange of this network

When connecting, openvpn choked on adding a route ; so I had to determine the peer IP (“via”), add it as a single host static route to my client, then add a network static route to the “grouped network”.

Be sure to add a separate network (LAN) for the VPN users. Don’t use the main LAN. Then allow this VLAN (used by the VPN users) to communicate with the LAN. There’s a setting when creating the VLAN to allow it to access devices on the LAN. Set up a DHCP server for the VPN VLAN segment. That’s all I can think of right now.

Thanks for your answer. I didn’t find any settings to explicitly link these things together (except by using overlapping subnets) or set the ovpn server peer IP (I had to find it out from the client’s logs).
The FusionHub settings for ovpn are really dry, I hope future version will add the required settings so I don’t have to fiddle the client config files manually!