Starlink healthcheck issues - Connection good using directly on wifi but peplink keeps dropping with DNS failure, tried ping option.

Hi all

Having continual issues keeping starlink connected to Peplink Balance 310 HW4

Have setup with guides in forum so that it can continue to use its supplied router and allow access to software control panel for starlink.

Connection drops regularly, every minute basically, have tried DNS and PING type healthchecks using and

Have tried googling issue and have had a look at other posts and most seemed to suggest trying a ping instead, which i have done.

I could be setting it up wrong, i am no expect, screenshot attached.

I have no idea why its doing this, when using starlink directly over wifi through its supplied router starlink is holding connection well with good download etc 150mbit plus and 15 down, all seems to work.

Have resorted to just disabling healthcheck at the moment, and it works fine but obviously cannot detect if Starlink service is actually down or not.

Using speedfusion with a 4G sim, but i do not know that this is that relevant as it seems the issue revolves around the peplink box thinking starlink is down when it is not.

Any advise would be appreciated.



I suspect it is related to the port compatibility issue between Balance 310 Hw4 and the Starlink ethernet adapter then causing packet loss. Please refer to our knowledgebase here. A workaround is putting a switch in between Balance 310 and Starlink ethernet adapter.


Is this a issue on a 20x as well?
I see a lot of drops on this 20x, but coud be just starlink itself.

1 Like

I had to put a switch between mine and starlink I have 20x, support said I should not need to but it helped. Also as of the last week SL has been pretty unstable for me, I have two connections so things have been fine but may be why your old method does not work. I currently use DNS check with a 5 second timeout for SL and have had no “down” notifications except for at 2am when SL updates etc.

Have tried this today (switch between starlink router and peplink) and unfortunately the issue is identical, still WAN failed PING test, tried DNS type too.

I believe starlink is actually fine and the issue is this heath check not working correctly with starlink.

Failing every minute basically. I have it set to timeout 5 seconds, health check interval 5 seconds, retries 3, recovery retries 3.

Not experiencing starlink drops using it directly over wifi without the peplink.

If i disable the heath check it all seems fine and in a sense better because the Peplink is not avoiding the starlink connection after deciding incorrectly that its down.

The obvious issue here is that the health check exists for a reason and i cannot use it at present with my setup as it is.

I have left the health check off, and i am running two wan (Starlink and EE 4G) through speedfusion setup, if starlink was actually down in real life, should this setup keep us connected?

Its not ideal to tell the peplink box that this starlink wan is good with no checks to make sure it is running.

Any other suggestions at all?


Hi @Kieran_Collings

it is interesting what packet loss you experience from B310 to via Starlink?
What is your Starlink model?

We recommend such HC PING values with Starlink:
Timeout: 5
HC Interval: 10
HC Retries: 5
Recovery Retries: 3

Alternatively, you may try 100 Mbps FD port speed on B310 WAN port (if you experience packet loss, you may not achieve more than 100 Mbps down, so reduced port speed might be a workaround)

Starlink at certain times is achieving 160mbps down here and other times less, but our 310 box has its own limitations on throughput as you will know, we are using speedfusion.

Have dropped to 100mbps down and 30mbps up as i know the up is not that powerful.

Have set the HC setting to what you advise.

We will see what the event log brings but actually it seems to be holding already, a good sign :slight_smile:

I see weirdness with BR2 Pro 5G with starlink connected to ethernet wan port that was working fine will suddenly go into “Connecting…” and spin endlessly. Nothing I do will allow it to resume working. Rebooting the Peplink it connects immediately. Makes me think the problem is on the Peplink side. I’m going to open a ticket

If the issue is the AR8033 WAN/LAN ETH chipset, why would the Balance 310 not have been listed in the original knowledgebase using this chipset? Begs the question if there are other Balance products using this chipset not in the knowledgebase.

@BeachComber1 ,

Only B310HW4 is missing from the list. We will add that. Thank you for pointing that out.

There are 2 issues reported by Stalink users to Peplink support:

  1. Port Compatibility (Only happen for certain Starlink disk version)
    This have been well explained here

  2. Starlink connection packet loss issue (Satellite Link issue for different location)


I have been experiencing the same problem with Balance 305 and Starlink Gen2 since day 1.

Is Balance 305 affected by the same compatibility issue as Balance 30 Pro etc ?

Has this issue been resolved? I am having the same issues on the balance 20x I tweaked the health check, I put an unmanaged switch in between the starlink router and peplink router but still I keep failing the health check.


I’m using the 20x, other then putting a switch between the SL router and peplink and tweaking the health settings did you do anything else to make it work? I’ve done everything that was recommended on here. Yet I’m still failing health checks.

What does your starlink obstructions and network statistics → uptime → outages look like in the app?
Additionally try to login the starlink website to look at your dish, I have seen for another client that it shows there if the cable is damaged and only linking at 100mb.

1 Like

Starlink had a bug with 3rd party routers… If if you put back the original router with double NAT it worked. They released the 3dca6b5d-2dbe-4eef-8091-75efdef3e5b9.uterm_manifest.release software update, that fixed the issue.

1 Like