Starlink connection thru Max BR2 Pro WAN port failing


I have Starlink connected directly to the WAN 2 port and configured as a Starlink (w/ firmware 8.4.1). All have been working fine until this afternoon, when I see that I have “No cable detected”. WAN 2 port is blinking orange on both the left and right LED every 3 secs. However, I’m able to see Starlink thru the iPhone app (iPhone connected to the Max BR2 Pro wifi AP). The Starlink App shows that it is online and is connected.

I moved the Starlink connection to WAN 1 port and now I can see that the left LED is showing solid orange (occasional blink) when WAN 1 is disabled. But when I enabled WAN 1 to priority 1, I lose the orange solid light on the left LED and the dashboard shows “No cable detected”. But my starlink app on my iPhone is showing that Starlink is online.

I checked that Starlink is actually working when I plugged it into another router. So I eliminated that the Starlink itself is a problem - best I can tell.

Hope some can help here.


Ahoy there!

We’ve seen sometimes that the cable or PSU fails, and therefore can’t properly negotiate the port speed.

Can you try and configure the port to 100 Full Duplex?
MTU 1500
Set WAN Health Check to PING, and set

If that fixes the problem, I’d investigate the cable, power supply and finally submit a ticket to Starlink.

See if that helps!

1 Like

Thanks Cap. Tried your suggestion and still no good. Somehow, I don’t think the problem is with Starlink. I’m able to connect Starlink to a Google Mesh router’s WAN port and it works perfectly fine.

Interesting - So, the only device unable to connect is the BR2?

Have you tried a laptop/desktop straight to the Starlink?
Can you try swap to another WAN Port?
Maybe also try configure a VLAN WAN and test a LAN Port?
Have you tried setup the Starlink Wi-Fi and use Wi-Fi wan from the BR2?

Would also be useful to know how it’s all connected, and what type of Starlink you’re running.

Be curious to see where it fails.

Please feel free to share some images as well but remove all sensitive info before posting.

1 Like

Cap, thanks again. I’ve found the problem. Looks like I do have a faulty connection afterall. I’ve corrected it and all is good again.

1 Like