Starlink and Max Transit Duo SLOWer than Starlink by itself ???

Peplink has posted the most current information regarding Starlink compatibilty here. The original post and replies remain for historical reference below:

I want to first say - I have been so incredibly happy and grateful for my Peplink MAX Transit Duo CAT 12!! it’s been life changing for our full time RV lifestyle! I’ve recommended and have sold many of them to fellow RV’ers I’m no PRO and am in need of some help!!!

we got our starlink about a month ago and have been using it with our Max Transit Duo using the WiFi as WAN feature with both the 2.5ghz and 5ghz wifi from the starlink router. Getting much slower speeds when using Starlink in this configuration. For example. I’ll pull a 50mb down with Starlink router directly (using and will only get roughly 25-30mb down when using WiFi as WAN???

We just got our Starlink ethernet adapter yesterday and used the “by pass” feature on the Starlink router and the connection is even worse? It’s literally not working or speeds as low as 15mb down. been using “” for all tests. Another strange thing is that the Starlink WAN connection is in priority 1 position with my T-Mobile SIM in Priority 2 position on “stand by” yet when I do a speed test the server states that it’s pulling from “T-Mobile” WTF? (see pics) Stranger yet - If I disable my T-Mobile connection by dropping it into the disabled section and then do a speed test I literally can’t get one meaning there is no internet even though Starlink says “connected” and green dot. Hmmmmmm. If I do the opposite and disable Starlink and use the T-mobile connection, I get internet and speeds around 35mb down.

I had to disable Starlink in order to send this email via the T-Mobile SIM! Yet if I were to reset the Starlink router, create a WiFi SSID, join it I’d get fantastic speeds and be able to send this email. Something isn’t right and I’m not sure where to begin???

What am I missing? why would Starlink work just fine on it’s own using the Starlink router and then work little to nothing with pepwave max transit duo? I will say this - I’m not a network expert but have extensive knowledge of many types of routers and interfaces and know enough to get myself in trouble. What should I be looking at?

Some known settings - I am using a bonded fusionhub via VULTR that i set up on my own. I am using VLan’s


Interestin, following this as i think k am seeing the same issue

Following… I’m waiting on gear, but my plan is to use this same setup.

Seriously terrible! I literally have no internet whatsoever using Starlink with Ethernet adapter or WiFi as WAN yet I’m pulling 200+mb using the starlink router bu itself. This sucks because I want my network to stay with Pepwave. What is the problem???

have you opened a ticket? if so, post the ticket # here.

1 Like

Yes, I opened a ticket #22050723

Have you tried locking your DNS to and

yes, I have. doesn’t make any difference, sadly

The older CPU in the Duo just won’t support those speeds, especially bonded:

"1 Gbps Router Throughput - The MAX Transit Pro has a much faster core CPU, capable of routing data at 1 Gbps. This is more than two times faster than the 400 Mbps claimed by the original Transit, and we frequently saw the original MAX Transit cap out at 150 Mbps in real-life usage.

400 Mbps PepVPN Throughput - The MAX Transit Pro’s faster processor can also support faster speeds when using Peplink’s VPN services like SpeedFusion. On the original MAX Transit, PepVPN throughput was maxed out at 100 Mbps unencrypted and 60 Mbps for encrypted connections. The Pro raises this to 400 Mbps and 200 Mbps respectively. "

Doesn’t explain why he’s seeing slow throughput on just the Starlink via physical WAN but you are correct that having 1Gbps is the way to go for the full setup

From the description, it looks like the Transit Duo WAN is connected but user traffic is not passing through, this is rather strange!

@todd, I have notified our Support Team (who owns the ticket) to work with you to find out what went wrong with the setup.

BTW, I am not sure others who have the Starlink Gen 2 with Ethernet Adapter are experiencing the same situation?

1 Like

I’m experiencing this same problem. My ethernet adapter came in for my Starlink and trying to get it off Wifi as WAN and use the WAN port, however when I have starlink hooked up this way my packet loss is over 50%! Doing a continuous ping to results in the attached screenshot.

This only happens when the ethernet is going through the Pepwave router. I have tried in bypass mode and in NAT mode. If I plug the ethernet adapter/cable directly to my laptop, I have no issues with packet loss. See attached.

I contacted MobileMustHave which is where I bought it from and they said that Peplink released a beta firmware (8.2.1b01 build 5364) this morning that fixes the issue, however after installing it, I still experience the issue. Not sure why it only happens when plugged into Pepwave WAN port. Works great if it doesn’t go through Pepwave router and access directly.

Trying to get all my connections to be centrally managed through Pepwave for easier management.

Edit: Adding some speedtest results going through the Pepwave WAN port.

Edit 2: I was able to kinda get it working (at least no ping loss). On the WAN details, I changed the port speed to 100 Mbps Full Duplex. That seemed to fix the packet loss, but I cannot seem to get any faster than 10-13Mbps on a speedtest this way. But it allows me to at least have it go through the Pepwave.

Speedtest directly with ethernet adapter with laptop:

yes, going through the pepwave trans duo I also get a much higher latency like 200 vs starlink alone i’m getting 40

Thank you! I did hear from mobilemusthave support and hopefully they can help me resolve this.

yeah, I see what you’re saying but i’m seeing max speed of 35mbps so the Trans Duo still isn’t living up to its potential.

Ok a few questions.

System- ping: can you ping from the pepwave via the starlink connection using the built in ping tool on the pepwave. use and see if it is reachable. This will prove if the pepwave has access to the internet via the starlink connection.

Advanced - outbound policy: is this configured to specifically use the tmobile connection using meaning it refuses to use the starlink connection? This might explain the lack of connectivity when using starlink.

Is your mobile also using tmobile, I’m guessing the speedtest is using the local sim in the phone as it doesn’t have access via the pepwave? which may explain why you see tmobile on the speedtest when it is p2.

From the other posts it sounds like there may be a autonegotiation issue with starlink ethernet adapter . I don’t know but does the starlink management system allow you to set a port speed but if it does try setting this to 1000/FD and then do the same on the pepwave side and retest. If not then on the pepwave side try setting it to 1000/fd and tick the advertise button. A bity of googling though suggests that a lot of people are seeing poor speeds on starlink using the ethernet adapter so a look through there forums or a chat with there support might help.

I am wondering if MTU and MSS might also be worth looking at as it may be that packet fragmentation is playing a part in issues you are seeing but I would check the above first to see if any of it help’s.

Same problem - lots of lost packets with ethernet. When I plugged SL straight into my macbook pro - worked perfectly. Following suggestion from post in this thread, I changed interface to 100Mbps FUll Duplex and zero lost packets. Either Max Transit Duo can’t really receive packets at 1G or the Max and SL aren’t negotiating full/half duplex properly. 100Mbps may limit what SL can download. However, after setting to 100Mbps I did a speed test and according to Pep/status/realtime - I was hitting 36Mbps download - so the math doesn’t make sense.

1 Like

Starlink doesn’t allow you to set the port speed at all. Seems you have to rely on auto negotiation. The only thing you can do is view the debug data and see that it shows if it’s running at 10 or 100 “slow Ethernet” but not that it’s Full or Half Duplex. Setting the pepwave to 1000Mbps Full Duxplex only with “Advertise” didn’t change anything.

Now this is really interesting. Working with Peplink support, he asked if I had a switch that I could put in between the Starlink Adapter and the Pepwave WAN port, which I did. So I hooked it up and what do you know? It worked!

Starlink —> Ethernet Cable —> Switch —> Ethernet Cable —> Pepwave WAN port

So it has to be some sort of auto negotiation issue. It can negotiate with the switch just fine but not to Starlink adapter directly. I used it like this yesterday afternoon and it has been great! Hopefully support can figure out the root cause and come out with a fix so I can take the switch out of the middle.

1 Like

Yeah same for me. Setting to 100Mbps shows that it’s connected at Slow Ethernet on the Starlink app, but couldn’t get any after than 20Mbps. But no packet loss which was the biggest issue. Pages load now and I can centrally manage the connection.

Using a switch in between resolves the issue and allows me full speed connection to Starlink. 150-200Mbps.

are you using this in bypass mode? your Debug Data looks like you’re still using the WiFi SL Router? I can’t seem to find the “Alerts, LanEthSlowlink10” or like your pic above. I’m curious as to what exactly you mean whey you say, “it worked” what worked? Are you saying that SL via the Ethernet adapter doesn’t work at all unless you’re using the switch?

Thanks for your participation in this thread!!! Todd