SpeedFusion seems to be a dud for me

I’ve used SpeedFusion Cloud several times in various locations and scenarios in the past couple months and have not had good results any time. Thinking it might have something to do with the SF Cloud I tried a test with just a VPN connection between devices. I’ll detail this setup below as I look for insight and hopefully resolution of the problem(s).

PepVPN link between a UBR_LTE and Balance 20x.

UBR-LTE:
Firmware 8.1.2 build 5054
2 WAN connections: One Verizon sim in the UBR and a T-Mobile Home Internet modem that is wired with ethernet to the WAN port of the UBR.
Speeds:
Verizon download is typically 8-12Mbps
T-Mobile Home Internet download is usually 10-25Mbps but sometimes even higher.

Balance 20x:
Firmware 8.1.2 build 5025
A single WAN connection from a cable modem.
Speeds:
Download is typically over 150Mbps
Upload is usually solid at about 18Mbps.

Results of file transfer:
SpeedFusion (both WAN active) = download speed between 500Kbps and 3Mbps

Verizon only (with VPN still enabled) = download speed 3-8Mbps

T-Mobile only (with VPN still enabled) = download speed 5-15Mbps

Test:
I connected from a computer at the UBR end to a computer at the B20x location and copied a 59MB file back to the UBR computer. While watching the Status->Speedfusion page in the UBR Web Admin I watched the speeds of the two internet connections.

Initially I had all the stock settings for the SpeedFusion VPN.
Encryption on.
Bandwidth limit off
WAN Smoothing off
Forward Error Correction off
Receive Buffer 0ms

With these settings I found that the Verizon connection was being largely favored and in fact, the T-Mobile connection was often showing latency of over 1000ms at which time it seemed like the speed would drop to <1k. So I tried adding some Receive Buffer.

Setting the receive buffer in the UBR to 20ms and the same in the profile for the UBR connection in the B20x I found the latency settled down. Latency for both connections typically ran between 35 and 70ms and the throughput was more balanced. Still, I never got speed even close to only using one or the other connection by itself.

I did not see indication of packet loss with the final settings (not sure about when the Receive Buffer was 0). The CPU load gauge of the UBR (on the Dashboard) during the file transfer generally hung around 50% or below.

Shouldn’t I see something in the range of 15Mbps with both internet connections active? Why does it drop so badly when they are both working?

Speed Fusion VPN was a complete disaster to test and try to use for me a few months ago…

Using a Balance 2 with two 50 MBS plus connections (one Fiber and one copper Cable) on one end.
Balance 20 with a 30 x 10 Fixed Wireless and two LTE Modems (one AT&T [Pepwave MAX BR1 Mini Core] and the other t-Mobile [USB modem]). (A Verizon SIM was also purchased through Ting, but Verizon would not allow it to be activated on a Data-only LTE modem device).
Both routers were less than a year old and running the latest version 8 firmware at the time.

The test case was a live streaming video uplink of a product demonstration from the location with the Balance 20 device. Live streaming was abandoned during the first event use. Video kept stalling. After that, uploads of recorded presentations were unreliable and often stalled mid-upload. Some recordings had to be transported via automobile to the other location to insure timely uploading.

Over the course of a week I tried every combination of all three connections on the upload, Balance 20, end (including turning off every Speed Fusion feature including encryption). Any combination of two or three internet links was slower than the slowest internet link used alone. It also seemed that both t-Mobile and AT&T would throttle their upload speed at some point on the LTE-modem data links. AT&T was worse than t-Mobile. Eventually, the usage devolved to turning off the Speed Fusion altogether and just using the Fixed Wireless connection with the t-Mobile on fail-over backup.

After a week the customer ordered a fiber optic connection from AT&T and this was used to complete the video upload project. This was done connecting the Balance 20 direct to internet, with no Speed Fusion turned on.

After the video upload project was completed I turned on just the PepWave VPN function (no Speed Fusion bonding, no features, no encryption) and connected the Balance 20 site back to the main Balance 2 site for, lite duty Remote Desktop use. This was also problematic and the VPN function was abandoned. There were still freezing and random lockup issues with the router (no traffic in or out, CPU at 100%). Eventually these problems led to the RMA of the Peplink 20 device.

The RMA’d Peplink 20 was replaced by a much older (but always reliable) Peplink 20. When put in place the old Peplink 20 was upgraded to the latest version 8 firmware. This device also locked up in the middle of the night when it was not being used. The firmware on this device was put back to version 7.1.2 build 3575 ( the last version prior to version 8). Four other locations that had old balance 20s that had recently been upgraded to version 8 firmware also experienced random lockup events, and were restored to 7.1.2 build 3575. No lockup events before version 8, and none after reverting to 7.1.2 build 3575.

Final analysis:
-All of the carriers I have tried – AT&T, t-Mobile, and Verizon – are actively throttling hi-bandwidth uses like video streaming in my area. “Bonding” these together probably does not work unless you are using several different ones from several different carriers simultaneously.
-Peplink 20 devices do not have enough CPU capacity to actually run a VPN process even with encryption turned off.
-PepWave Fusion Cloud is a toy. You can tell by the price. Buy a block of data ahead of using it. Manually buy more when you run out. Don’t guess wrong about how much data you will need because there is not auto re-purchase method.
-PepWave Fusion Bonding is a sad joke. It cannot be made to work reliably with low cost mobile LTE modems. Or, maybe Peplink should stop pretending that it could work with a Balance 20 device.
-PepWave VPN is just too much work for a Balance 20 device to process and still actually use the device for in-house business Intranet uses.
-Version 8 firmware is malware. It is buggy and unstable. I would be foolish to NOT think that Peplink has new Chicom masters that insist on building in backdoors to enable cyber crime and warfare.

I have used Peplink 20 devices for years in this company to provide automatic WAN fail-over from fixed internet to LTE backup modems. The Peplink 20 has provided nearly problem free, high-reliability service. However, trying to use any of this PepWave Fusion technology was a complete failure. I tried everything I could think of and everything that was recommended, including from the great help I received from my vendor’s tech support and the really bad support I received from Peplink’s Hong Kong based tech support. Also, ANY of the versions of 8 firmware I tested caused recurring problems that were only fixed by reverting to the older version 7 firmware.

I would not recommend that you spend more time trying to make this work.

Dear David,

we understand your frustration. But your situation is not comparable with warren1. He is using the latest models from Peplink. But streaming with a Balance 20? There is no SpeedFusion Bonding on the Balance 20. So you will not get the advantages of True bonding. And it is a smallest device from Peplink. As you said normal Failover works great. But the load of SpeedFusion in the CPU would be too much. Hence Peplink is offering no SpeedFusion Hot Failover, SpeedFusion WAN Smoothing, SpeedFusion Bandwidth Bonding. If you want to use SpeedFusion you will need to choose a higher device.

@cwarren1
I would suggest to open a ticket with Peplink and share some screenshots about your policies and cellular connections with them. Perhaps there is something in the configuration you missed.

BR Mandy

Mandy,
Warren1 is trying to do exactly one of the several things I tried to do using a Peplink Balance 20 device with another Peplink device.
Peplink should not sell a non-refundable license to use on a Peplink device that the feature cannot work on.
Please stay out of this conversation.

Hi David,

The Balance 20 has no ‘official’ SpedFusion license, just a PepVPN license (PVN-LC-05). You can find the difference in below diagram. PepVPN has no bandwidth bonding or VPN Bonding over multiple WAN links.

warren1 is trying to use a Balance 20x.


https://compare.peplink.com/?series=balance&product1=BPL-021&product2=BPL-021X-LTE-US-T-PRM&product3=BPL-031-LTE-US-T

To be fair to your nitpickery, a Balance One device licensed for 3 Wan ports and SpeedF


usion Bonding was used for the failed multi-WAN Bonding portion of upgrading this network. The Balance One device failed to provide any benefit using Bonding, in exactly the same way that Bonding failed for warren1.