SpeedFusion routing conflict on a physically disconnected (but not disabled) WAN

I don’t know if this is a bug or simply a gotcha for the unititated:

Background:
Test setup:
Balance 380 HW6 FW 8.1.3 as a fusionhub, LAN 192.168.15.0/24; WAN #1: 1Gbps fiber, DHCP IP; WAN #2: DSL, static IP; WAN #3: Not connected, enabled, DHCP.
Balance 20X FW 8.1.3 , LAN 192.168.12.0/24, DHCP on, WAN: 2 x cellular (it has a flex module)

Summary:
The DHCP-assigned IP address on a WAN connection seems to linger on in the routing tables even after the WAN is physically disconnected.

Setup #1:
B380 WAN #3: Connected to B20X LAN #1. IP address assigned to B380 WAN #3 is 192.168.12.2. All is well.

Setup #2:
B380 WAN #3: Disconnect the ethernet cable from the B20X and the B380 WAN #3 port, leave B380 WAN #3 port enabled (reported as “No Cable Detected”)
Establish a SpeedFusion connection between the B20X and the B380
Error report on the B380: Route conflict on 192.168.12.0/24 (even though 192.168.12.0/24 is not reported as being available anywhere).

Setup #3:
B380 WAN #3: Set the port as disabled. That clears the conflict.

Setup #4:
B380 WAN #3: Set the port to enabled again (back to “No Cable Detected”). All is still well - no report of a route conflict. Presumably the toggle of the enabling of WAN #3 cleared some table somewhere.

@zegor_mjol ,

Supposedly disabled the WAN will clear the IP address obtained for the DHCP WAN. Do you still have the device running ? We can check from the device to confirm. Anyway, WAN IP for the B380 not suppose to design using the same IP range for the remote devices .

Feel free to check the units. Ticket #21080579 (low priority, of course).
I left them in the route conflict state (WAN3 connection between them unplugged, SF between them enabled).

1 Like