Speedfusion Cloud FEC & Smoothing

Sorry for the noise-level question, but I’m having a brain halt. I set up Speedfusion Cloud (still in the trial period & still have time & data left) on my Balance One and I created FEC, Smoothing & Normal tunnels somehow, but now I can’t find the settings for that. I’m trying to see whether the FEC tunnel is set to High or Low.

Thanks,

Mark

My SpeedFusion Bonding trial expired (not Speedfusion Cloud). I wasn’t using PepVPN, but is the SpeedFusion Bonding license required to set FEC or Smoothing options in SpeedFusion Cloud? Or did the expiration of the trial just mess up my configuration?

When using SpeedFusion Cloud, you do not need the SpeedFusion Bonding Licence.
FEC & WAN Smoothing Settings for you SpeedFusion cloud Tunnel are available under the SpeedFusion Cloud tab and click on “Choose Cloud Location” then you can click on the SpeedFusion Cloud tunnel and edit the settings.

1 Like

Thanks very much for your reply.

That’s where I thought it was, but it’s not there now - see attached screenshot…

Does anyone ideas on why the FEC & Smoothing configuration options have disappeared? Could it be because I’m still on the trial data plan?

@mc1z, this is a bug, and it looks like happened to Balance One. WAN Smoothing and FEC are available in my MFA 500 which is running 8.1.0 as below:

We have filed this bug and will fix it accordingly.

May I know WAN Smoothing and FEC are mandatory for you now? Can you share what services are running in your network?

Thanks.

3 Likes

@TK_Liew - thanks for letting me know. FEC & Smoothing used to show up on my Balance One, just as you show in your screenshot - that’s how I initially created the “FEC” & “Smo” tunnels you can see in my screenshot. I’m not sure exactly when or why the options disappeared.

My network is a home office in an area that has poor internet. I do various work associated with software development, plus the usual things related to home & recreational use, but my usage for FEC & Smoothing is that I host a lot of meetings using Zoom & Google Meet.

My WAN configuration is a Suddenlink 10/1 cable ISP (WAN 1), an AT&T 3/1 DSL ISP (WAN 2) and an AT&T Wireless Netgear hotspot for backup (cellular USB port). The Suddenlink connection should be called Sudden Unlink, because it goes down 10-15 times per day on average, but usually only for a minute or two at a time. It’ works great when it’s working, though. The AT&T is a lot more reliable, but barely fast enough to handle Zoom meetings with more than a few participants, and sharing videos via Zoom is where I have the most difficulty. If it were possible to give Outgoing packets absolute priority somehow, that would probably help a lot, but perhaps that’s not possible…

Thanks again!

1 Like

WAN Smoothing or FEC is needed only when you have a bad streaming quality which causes by packet loss. You may check here to confirm any packet loss there.

You should able to prioritize the Zoom traffic.

  1. Define the upload and download bandwidth limit in SpeedFusion Cloud profile.

  1. Enable Application Prioritization

  1. Ensure all your traffics are routed in to SpeedFusion Cloud.

Hope this helps.

2 Likes

@TK_Liew, I really appreciate your time in detailing those options. I have done each of those things. I have also assigned the W10 PC that I use for sharing the videos to be the only device with Manager status, given it a high percentage of the total bandwidth, etc. but, incoming video feeds still seem to seriously degrade the uploaded video quality. For example, if I host a Zoom meeting with only a few participants, shared video to them is very good, even without FEC or Smoothing, but if there’s more than a dozen or so, and their cameras are on, when I share a video, Zoom thinks there’s a lot of packet loss and drops the quality from 720 or 1080 to 360 or less. It doesn’t make sense to me that downloaded data (that I’m not even using - I use a separate iPad to actually participate in the meeting, and yes, the camera & mic are turned off when I’m streaming from the PC, to prevent it from competing with the video) would interfere with my uploaded data to such an extent. Perhaps it’s totally a Zoom problem, but getting support from Zoom right now is like trying to teach a pig to sing: it wastes your time, and it annoys the pig. The bottom line is that I should have way more than sufficient bandwidth to do what I’m trying to do, so the bonding of the cable & DSL ISPs should essentially be providing failover capability only, but it’s not working out that way…

Thanks again for any and all assistance - I’ve been messing with this for months now, and nothing seems to help much. I actually believe that the thing that made the most difference was the Manager bandwidth feature, which is my most recent attempt at getting this to work properly…

The only thing you mention above that I’m not doing is #3 - making sure all traffic is routed through SFC. I’ve been trying to run only the W10 PC that’s hosting the Zoom meeting through the SFC. I thought that would rather guarantee that the PC had priority traffic over everything else by default, but if that’s not the case, I’ll be happy to route everything else through the SFC cloud tunnels, too. I’ve sure tried everything else I can think of, even if didn’t make sense to me…

1 Like

This bug appears to be affecting a Balance 20, running 8.1.0, as well. A firmware fix would be very appreciated.

Thank you.

Also seeing this bug on a SoHo MK3. I have to say, Speedfusion cloud combining a wired wan and wifi as wan link, with multiple Speedfusion cloud subtunnels, is impressive on a device as inexpensive as the SoHO MK3. Restoring the ability to enable WAN smoothing would be the last step, so I could test this, paired with a cellphone hotspot, with some of our users having trouble keeping wired VoIP phones connected on intermittent cable ISP connections.

Hats off to Peplink for such an inexpensive and potential solution to our problem.

1 Like

@mc1z, your problem seems like relating to the lack of bandwidth. Please check what is the real-time throughput (Status > Real-time) and SpeedFusion Cloud throughput (Status > SpeedFusion) when you see the quality if Zoom is bad.

2 Likes

@TK_Liew This doesn’t appear to be the case. I monitored the throughputs you mentioned and there’s typically less than 5MB/s down & .8 MB/s up when the problem occurs. I should have a combined total 18 down and 2 up. There was very little other traffic down and none up at the time. It seems to me that the prioritization of SFC traffic isn’t being handled properly. (At this point, the only traffic going through SFC was the zoom hosted video. All other traffic was using the Speedfusion/AT&T DSL WAN Overflow Outbound Rule.)

@mc1z, can you provide screenshots of real-time throughput (Status > Real-time) and SpeedFusion (and SpeedFusion Cloud) throughput (Status > SpeedFusion) here?

With the addition of closer SFC locations, I’m going to try using one that’s a lot closer to me, along with a purchased data Top Up to try the faster VPN speed, as well. Unfortunately, I still can’t adjust the SFC settings, so I’ll just try a tunnel without FEC or Smoothing until there’s a firmware update…

I’ll update this post with the results of this change…