Speedfusion Cloud causing problems?

Hi all,

Got a weird problem here but I cant get to the bottom of it.

Every time I start streaming with OBS using the cloud service it drops loads of frames and makes a completely unusable stream.
If I plug the stream laptop into any of the 4g or fibre lines it works perfectly fine.

So to test a theory I have 3x 4g/5g routers and a fibre line at work. I also have a max700 with cloud bonding enabled and I also setup a speedify+connectify bonding PC. Traffic on both is being bonded.Stream setting is set at 4500kb.

I ran a cable from each 4g/fibre connection to the peplink and speedify routers. Installed OBS on the laptop and tested. So same internet, same laptop, same stream settings to the same streaming server.

Start OBS on the peplink and it dropped frames, not 1 or 2 but maybe 20-30% of all frames for the duration.

Start OBS on speedify and its perfect, perfect every time and runs for 12 hours without a glitch.

I have spent a few days testing this and the results are repeatable.

It looks like something in the peplink router setup. FEC has been left on High, WAN smoothing has been tried on all options and not a single thing makes any difference.

Any ideas?

Cheers
Rich

Right so an update…

OBS just won’t work, given up with that. I have tried broadcasting to a few of the popular streaming platforms and its just rubbish. Low frame rate, disconnects, poor stream quality only when speed fusion is used.

So a change of encoder and Wirecast and Vmix both work fine for me with speed fusion. Wan smoothing set at normal and FEC set to High has given me good results for the last 24 hours.

I had 2x test streams running on the 3x lte routers and 1x fibre line and took turns puling cables out, giving it time to re-establish the speed fusion link then do the same again it worked really well. I’m lucky I have minimal latency on most of the 4g networks so its looking good in a test scenario.

So, I have a solution for the time being even though it’s going to cost a few grand more than expected.

What’s bugging me is why doesn’t OBS work? It’s streaming to the same platforms, on the same internet connections, using the same RTMP protocol and bit rates but it’s not happy? Why would it see the speed fusion setup as something different to the other streaming software solutions?

I can confirm that I had problems with streaming (Apple TV, Apple Music, Amazon, TV Apps, …) using Speedfusion Cloud (Server Frankfurt, Germany), too. Support confirmed, that it is possible that Amazon and Apple are blocking the new public IP address which comes from the cloud provider. This way they want to avoid giving service over VPN. The same thing is happening with Netflix.
They don‘t distinguish between VPN and bandwidth doubling / increase, unfortunately.
Don‘t know if Peplink is able / willing to reach out to this big media content providers to find a solution…
Could lead to kind of e.g. German SFC users can only use German SFC Exit at FRA to avoid VPN tricks.
Only solution that I see currently is using a hosted Fusion Hub Server with fixed IP (costs additional money).

You gave lots of information, and I apologize in advance for my ignorance in response. I don’t use Speedfusion. I also have not heard of speedify+connectify.

I do spend some time on this forum and have seen posts that pretty much say that links with high variance in latency (one at 100ms ping to gateway and one with 1ms ping to gateway) are not very good candidates for Speedfusion. I can’t tell if that is what you are experiencing, but mixing an LTE link with a fiber link is probably a bad play. I don’t have the answers for you, but maybe some questions will be helpful?

What peplink gear are you using? What kind of Speedfusion bonding are you attempting? (I think there are options, right?) What does your outbound policy look like? I assume you want to stream from home - what is the setup there? (including your work connectivity may or may not be helpful in resolving your issue). What are your goals with Speedfusion? (high availability or capacity doubling)

There could also be something in the actual packet size (MTU) or the links as it pertains to what OBS is producing. If devices are cooking CPUs disassembling and reassembling packets – that would cause some jitter/drops. The mystery continues…

@rich205, since you tested Wirecast and Vmix are working fine with SpeedFusion Cloud, this looks like something is happening to the OBS streaming. I need more input from you:

  1. May I know which Cloud Location you are connected to? You may check at Status > SpeedFusion. Below is the screenshot.

  2. OBS is just a streaming tool. Do you know where the destination is (streaming server)?

Cheers for the reply’s everyone.

I have tried connecting to the local speedfusion site London SFC-LON-002, and now just left it on automatic.
Vmix, Wirecast and OBS all used the same stream key to either boxcast, vimeo, youtube and my wowza server. Its a repeatable fault across multiple pieces of equipment.

This kit has had to go to site now for a event.

This job, at a new site currently bonds 2x fibre lines and 4x LTE sims from different vendors, minimum data rate on a sim is 8mbit upload upto 30mbit. Max latency on all 6 connections is around 50ms in use on the LTE, and sub 10ms on the fibre. Tested individually I should have around 150mbit upload capacity

I get 18mbit in speedfusion. Just about enough to send 2x 3mbit cbr streams from a single location. None of the LTE connections are building big latency in speedfusion so something isn’t quite right.

In fact I get the same data rate bonded with just 2 or 3 LTE sims, or both fibre lines on its own, or all together.

If I take a single fibre line with 50/50 and speed test that I get 14mbit in the pepvpn test results.

I have half a dozen of these max700 routers, a pair of 380’s and only really started using speedfusion for work since the cloud service came live, so happy to be corrected or any help or guidance would be awesome please.

@rich205, OBS is just a streaming tool. It should connect to the OBS server which I think the server is at a different location with Vmix and Wirecast servers even you stream the same source.

I believe some fine-tuning is needed there. I suggest contacting the local Peplink partner (should be your point of purchase) to get support on this.

Thanks.

@rich205, I personally use OBS for streaming to YouTube over SF Cloud every week and it works just fine (TCP stream). From your latest reply you’re talking about performance issue now, so is OBS problem solved? If not, can you share your OBS and YouTube settings so we can try to reproduce the problem?

So a update…

We have managed to get our heads around a lot of the bonding issue, just lots of trial and error to get a understanding of how its working.

We only use the Speedfusion cloud service, so it appears a little more limited in options available but we are beginning to see positive results.

We can bond 2 similar lines eg vdsl 18Mbps upload lines to get a overall upload throughput around 90% of the combined bandwidth available. That’s great.

2x super fast fibre lines not soo good but still around 60-70Mbps. I thought we could max this as individual lines can hit 80Mbps on their own on the speedfusion monitor and our routers are limited to 100Mbps for the tunnel.

Mobile 4g is a lot better now, but we have to stack multiple cards from different cell providers. By changing sim cards and using udp traffic we can get around 60mbit upload but we are using 4x sims to get this. We haven’t changed the lte routers or antennas as latency was always low on these.

As for OBS and Wirecast the issue is just with FEC, though I still have no luck, streaming to vimeo, wowza, boxcast or youtube FEC still drops frames. WAN smoothing works so that’s what we use for the time being until we have a bit more time to work out the reasons why.

I’ll be back in the near future with more updates, but we are working onsite for the next few weeks so may be a bit slow.

1 Like