Speed differences from mobile device (iPhone)

I repeatedly see significantly better speeds on my phone than I do through my MAX-BR1-MK2-LTEA-W and I would appreciate some thoughts regarding why, and if there is anything I can do to improve things.

For example, just now, I configured my Pepwave to use my T-Mobile sim. I have a T-Mobile phone (iPhone 11) on the same plan.

Turning my phone’s WiFi off and running Speedtest, I’m seeing 100Mbps x 4Mbps. If I put the phone back on WiFi (turn cellular off) and run Speedtest again, I will get a fraction of that download speed.

If I run Speedtest from my laptop through the Pepwave (using WiFi) I might see 9 x 5, or even 4 x 5. It is not at all uncommon to see uplink speeds higher than downlink through the Pepwave device.

Similar Speedtest results will occur if I switch to Verizon and compare with another phone. Although, in the case of Verizon, the two SIM cards are from different accounts.

Some has to do with the provider, the phones get more data usually then a data modem, some has to do with the category of modem in the device, for example:
Your Iphone likely has a CAT-18 data modem in it the BR1-MK2 is a CAT-6 data modem.

1 Like

I’m skeptical.

First, the kind of browsing I’m talking about, even to simple web pages, should be doable with a CAT-6 data modem. Occasionally things work fine, or at least acceptably.

I do suspect the cell company but let me offer this morning’s anecdote as an example.

I could not get a good connection using my Verizon plan with download speeds around 0.2 Mbps (btw, I’m in the middle of a major US city). So, I switched over to my T-Mobile sim and started getting a reported 20-30Mbps down, but browsing itself didn’t improve. So, then I tethered my laptop to my phone and boom, Internet! Of course, the problem is I’m limited to how much data I can use with my phone as a hot spot.

To recap, sometimes I can get good speeds from Speedtest, but still can’t get routing (i.e., browsing) to work worth a damn. The connection is slow and will freeze. It is rare I can get an RSRP > -100dBm, and the bands I’m connected with seem to jump around (I get that could be the cell company).

I am having trouble being convinced T-Mobile is differentiating between hot spots, but I do accept it is possible based on amount of data the device has used on their network. The monthly cycle ends in a few days and this may be a good test for that since we’ll still be parked in the same spot.

The real reason I came into these forums is to try and determine if there are some additional steps I can take to test the device itself to see if it is failing. I am in the process of reinstalling an omni external antenna, but in the meantime I place the device near a window. Given my location in a metro area, I doubt the external antenna will be a major improvement. I’ve also done a factory reset on the device but, that hasn’t helped either.

Other thoughts?

What’s the signal numbers?
How do they line up on this chart?
image

Current snap shot while on T-Mobile

RSRP -103dBm
RSRQ -8dB
SINR 15dB

Browsing on multiple devices is slow or even unusable, although it seems to be even worse on one laptop so I’ll check into that as well.

I’ve had situations in the past where received power is acceptable but SINR or RSRQ are fair to poor. Possible antenna issues?

====
Edit: Going to pull back the statement that it is worse on one particular device. It seems to be hit or miss.

Can you try setting up speedfusion and running everything over that see if the speed improves?

I’m still trying to figure out how it works to improve speed. The video wasn’t of any help.

I was thinking that if you did a speedfusion tunnel the traffic would be encrypted and then the provider may not slow it down.

An interesting theory. Are there any real world examples of people having success with this?

I guess I’m willing to try although it feels less secure, less private and a bit like the Pepwave may be crippled unless the subscription to Speed Fusion is purchase.

I had a business tmobile plan that was specifically for IOT devices if it detected any user agent like chrome/ie it simply would not work. When I encrypted it everything worked fine.
You could also try changing your dns servers to 8.8.8.8 amd 8.8.4.4 if you haven’t done so already.

This is to be expected. You are comparing a CAT19 modem in the iphone 11 to a CAT 6 modem in the BR1.

The Cat6 modem in the BR1 can combine 2 carriers for both download and upload
To put that into context:

If LTE CAT4 was considered the Base line for LTE (1 x 20Mhz carrier) and we imagined data as passengers in vehicles on a road it might look like this:
image

Carrier Aggregation

CAT 6 in comparison then (which supports 2 x 20Mhz carrier aggregation) would look like this:
image

The LTE CAT19 modem in an iphone 11 pro supports 7x 20 Mhz carrier aggregation (download) so that would look like this:

image
That’s seven lanes of traffic compared to the 2 carriers in CAT6 which is a lot more data!

We also need to talk about MIMO

BUT… CAT19 it also supports 4 x 4 MIMO which if we stick to our analogy is like stacking the lanes vertically:

Then there is Modulation
Modulation takes any of the three RF chracteristics (amplitude, frequency and phase) and alters them to overlay additional streams of data using the same carriers.
In our analogy here then we can think of it as different vehicles where progressive modulation techniques let us squeeze more data (or passengers) into the same space:

image

CAT19 supports 256bit QAM modulation and although we wouldn’t see this in practice, in theiory that would mean this to our analogy: Yup. 4 levels of 7 lanes of double decker buses.

image

So if we finally compare the theoretical difference between CAT6 to CAT19 we have this:
image

Look at how many more data (passengers) we can potentially get through a CAT19 compared to a CAT6 it is significant - but its also very best case - lab conditions really.

In the real world you have loads of variables. There might not be all the available carriers on the tower you’re connected to, some of the carriers might be noisy which will mean that full 256 QAM modulation isn’t possible, and some towers will be over subscribed. You might have different antennas connected, two might be omni directional, two might be directional - so you get different signal qualities which would support different levels of modulation.

So a real world example represented as a diagram might look more like this:

image

But hopefully you can see that when comparing a CAT6 modem to a CAT19 modem, so long as they can both use the same frequency bands, a CAT19 modem should always perform significantly better than a CAT6 modem.

Download and Upload use different LTE Categories

Finally - for completeness its worth remembering that the different LTE release levels also define different categories for download and upload.

The Intel XMM 7660 modem in an iPhone 11 for example supports CAT 19 download:

  • 1600 Mbit/s
  • 7x20 MHz carrier aggregation.
  • Up to 256-QAM.
  • Up to 4x4 MIMO

and CAT13 Upload

  • 150 Mbit/s
  • 2x20 MHz carrier aggregation.
  • Up to 64-QAM
  • Up to 2x2 MIMO
11 Likes

Very nice explanation!

2 Likes

Lots of good information, and I get it.

But, I suspect, if one looks at my other symptoms it becomes (possibly) clearer that the real issue is not simply the different modems.

Let’s just focus on the CAT 6 modem since that is what I have (and I accept that the simple comparison I made to the iPhone was flawed. I was simply trying to highlight the continued problems I see).

For the last day or so, connection, speeds, and user latency (which I’ll define as what I experience when I try to load a website, but loading hangs) have all been pretty good. And my model was connected to two channels (LTE-A). Now, suddenly, this afternoon, I notice the modem has dropped out of LTE-A, measure latency has increased, and Speed Test results are weird:

I will highlight my comments above that I’ll experience decent Speed Test results at times, but browsing will still hang or be really slow.

What are the most probable potential causes of this type of experience?

Thanks.

FWIW, we have number of anecdotal examples of the traffic shaping being very different depending on whether the internet access is naked (i.e., simply employing the cellular connection as such) or by means of a SpeedFusion tunnel (i.e., all connections are going through a tunnel to a hub (we’re employing Balance routers and FusionHubs for that purpose)).

Naked connections tend to be more asymmetric (download much faster than upload) and subject to hotspot/tethering throttles and usage caps (where the carrier enforces such a policy).

Also, if one is employing (some) MVNOs or plans that have lower priority than the main carrier then we have experienced occasionally extreme sensitivity to the tower’s selection of LTE bands employed by the router for its connections. Limiting which bands to offer the tower can make or break the usability of a connection.

The above anecdotes are based on experience with network operators working with the Verizon infrastructure.

The short of it being that the carrier determines policies, connection parameters and priorities.

The Peplink products then provide the tools to tinker with a broad set of settings where one may optimize within the black-box environment provided by the carriers.

Cheers,

Z

3 Likes

Thank you for posting your experiences.

Will you clarify a few points?

  1. Have you experienced instances with your plans where reported upload speeds are higher than download speeds?
  2. When you’ve seen increased “sensitivity to the tower’s selection of LTE bands”, has that experience been at random and intermittent, and even when you’re stationary?
  3. Does the use of Speed Fusion improve your experience? Or simply give you better up/down balance? Or something else?
  4. Have you experienced a hardware issue that has caused the kind of symptoms I’ve described above? Or, in your experience, am I most likely simply seeing the effects of the carrier’s shenanigans?

Tim

Grab the cellular reports from IncControl2 for the same period. They will show you RSRP RSRQ and RSSI. Compare the periods when poor to those when better. What do you see?

Click the blue question mark on the cellular details screen to show the engineering data. Record that when good and bad and compare the differences.

Whats most likely is that the tower you’re connected to gets busy. Either from an RF perspective, or from a backhaul perspective. And then you’ll see weird latency events and you’ll get handed off between towers too - that’s one of the reasons for RSRQ - that calculated measurement gets sent back to your serving cell and it will sometimes push you to a different cell if your RSRQ is low…

In cases where I have seen this happen, the tower is saturated with people downloading from the internet, but upload bandwidth is not saturated. Last time I saw this was a fixed install, with 70Mbps up and 35-60Mbps down on CAT4 LTE modem.

In the UK, I have a customer who provides temporary connectivity using multiple mobile networks. One Mobile operator’s SIM plan blocks VoIP traffic. Encapsulating the VoIP in a speedfusion tunnel bypasses those restrictions. Other than that, speedfusion with Forward Error Correction and/or WAN smoothing can compensate for cellular connections with poor quality (eg jitter and packet loss).

Its always worth double checking antenna connections. Swap out any third party antennas for the included panel antennas too just in case - but what you have shown so far looks like an organic scenario, not a fault to me (although that 120ms of jitter is high…).

4 Likes

I have signed up for InControl2 and will try to get more of the data when I observe issues. Unfortunately, I hadn’t paid for it yet so this afternoon when I couldn’t maintain a simple Zoom call, I likely missed data collection from the sims. (BTW, who all can see this data?)

BTW, I don’t see a report specifically titled “cellular report”. Do you mean the WAN Quality report?

Thanks for sharing that. I didn’t know RSRQ got sent back to the tower.

I see this A LOT, in different areas (metro, rural), and aperiodically during the day.

Interesting. My past experience is that VPNs’ added overhead is pretty costly. But, that was years ago so I’m willing to try it again.

I’ve used three different antennas including the paddles. I agree it likely isn’t an antenna issue. And with nothing causing anyone to question the modem itself, I’ll stay focused on the cellular network.

I agree its likely to do with the difference in radios/carrier aggregation as well as carrier priority.

Best to make sure you are using same bands and connecting to same cell tower too.

Most carriers have 10+ levels of priority. First responder phones and business phone plans tend to get higher priorities. Then first responder data and business data. Then consumer post paid phone plans followed by consumer post paid data plans. Then pre-paid plans followed by pre-paid data plans. So if your tower is utilized, its possible because you are not deemed a high priority, you are not getting all the data others may get, especially in a phone plan that is a higher priority. The Peplink is an enterprise device. I’d suggest trying an enterprise plan to see if that gets you a higher priority.

Hey @MartinLangmaid,

Here is a six hour snap shot of my WAN quality.

I’m surprised to see RSRQ and RSRP to be unchanging. Does this make sense to you?

I just recently learned that cell providers may be using so many levels of priority, and that pre-paid is a lower priority than post-paid.

We use post-paid for my wife’s Verizon phone because it was significantly less expensive (at the time) than an unlimited plan which we didn’t need (because we have an unlimited plan for our Pepwave device). However, that phone has tended to provide the best service to us when other devices have been an issue.

Based on this, I have to assume the Verizon plan we have in the Pepwave is even lower priority than her pre-paid plan.

Do you have a source showing all of these prioritizations?

Thanks!