SOTG using Verizon U620L Modem


#1

Our provider has switched to the MiFi U620L cellular modem, which will no longer work with our current router.
In searching I came across this SOTG, I really like the features and size and looks like it would be a good candidate for our router.
However, I’m having issues with it. For the first 8 to 12 minuets it works great, then any device attached (wired or wireless) will have no internet connection, but the light on the modem and router
indicate it is still connected. Using the ping tool in the router, it will not ping 8.8.8.8 or any other address.
If i power off and on, this same problem will occur after a few minuets. I’m using the 010027 build 1265 bin.
This modem works perfect on other routers and laptops.

Does anyone have any ideas on how to fix this?

Also i did try our Pantech ULM295 modem in the SOTG and it works great, I think there must be a firmware issue with the U620L.

Jarid, I will try to call this evening.


#2

Hi Joe,

Below is the connectivity:-

User —> SOTG —> MiFi U620L —> Internet

Based on the testing, ping packet from SOTG reached MiFi U620L but not internet when problem occurs. We suspect something to do with the MiFi U620L settings. Jarid provided comments in the ticket. Please try it out and follow up in ticket.

Thank you.


#3

I am having this same issue with Surf OTG HW ver. 2.2 and my new Verizon U620L modem. Running firmware 1.0.28 build 1274 with FACTORY DEFAULT settings. Everything works fine for some interval of time and then forwarding stops completely. My UML295 modem never had this problem. Surf OTG still sees the modem with link, but no traffic flow. If I unplug and then insert the modem, it starts working again.

Is this a known issue? Are there particular modem settings I should be using?


#4

Hi Ted,

Your case was handling by Tech Support now. They will escalate your case to proper channel for further investigation. Thank you for your patient.


#5

They were never able to find a fix for me, I check every few weeks for the latest firmware and try again. It seem to be an issue with the USB driver.
Let me know if they are able to get your working.


#6

Hi Joe,

Sorry for keep you waiting. I will follow up with you using the support ticket and resolve the issue as soon as possible.

Thank You


#7

Greetings,

Surf On-The-Go, Product Code: SUS-AGN1 trying to use a Verizon U620L modem. Tried firmware builds 1265, 1274 and 1288 but no joy. Does anyone know if this will be supported sometime in the future, or maybe the SOTG is just to old? serial # 2830-C80E-695A
The U620L works OK on my MacBook, never connects on the SOTG.

best!
jim


#8

Please open a support ticket here:
https://contact.peplink.com/secure/create-support-ticket.html
Thanks.


#9

Thanks for the quick reply! :slight_smile:
Ticket #767301
best!
jim


#10

Was this problem ever resolved? I’m having the exact same problem and have submitted a support ticket.

Jeff


#11

No, they improved it to the point where it would stay up for about 50-60 minutes and have no internet again.

Please let me know if you get something to work.

Thanks


#12

I tried their suggested update to Version: 1.0.29 (build:1300) and still experiencing the same issue. I might even be able to live with 60-60 minutes, but I don’t make 10 minutes.


#13

Hi @grousesetters & @Joe_Davis,

Please open a support ticket here:
https://contact.peplink.com/secure/create-support-ticket.html

Thank you.


#14

This is the last one they sent me.

http://download.peplink.com/surfap/fw_010029s2_build_1294.bin


#15

Hi @Joe_Davis & @grousesetters,

Sent a private message, please check for information within.

Thank you.


#16

Still doesn’t work, anything new on this firmware.


#17

Please open ticket for us to check further.

Thanks.


#18

ticket 772228 opened in may …never resolved - router is a paperweight , save your money , find something else … it just doesnt work


#19

The U620L works fine with SOTG when we went in to check with you via RDP session. You do agree to report back if you encounter the similar issue again. Since you have the problem now, we will follow up with you in the ticket. Do let us know when the RDP is ready. Of course, if we can check when the problem is occurring then will be great.

Thanks.