Sotg mtu


#1

I believe I am getting some packet loss with my SOTG usb tethered. I have the mtu set to 1428 under the cellular settings tab on the SOTG. 1428 is what is used for lte. I have the SOTG ap disabled but use the lan port of the SOTG to connect to my netgear router to handle all my devices. When i run an mtu ping test with this setup in the command prompt 1428 results in a 75% packet loss. I know that 28 needs to be added to your final mtu number becuase of the ip headers. An mtu of 1400 results in no packet loss. That would mean 1372 is the actual mtu without the 28 added. Thats well below LTE requirements.

When i used to usb tether my verizon mifi 5510l to my asus router an mtu of 1428 never resulted in packet loss. 1428 is the mtu needed to LTE.

I believe the root of my random websites not loading and sometimes very slow loading of any website is the result of packet loss from what i gathered by using wireshark which we be cured by a correct MTU setting. Is there something wrong with the SOTG? Any ideas why this is?

Here is another instance of what I am referencing however the outcome of this discussion resulted in success.

https://forum.peplink.com/threads/5842-Allow-to-configure-WAN-MTU-on-SOTG

Heres another interesting observation. Today for instance I loaded up a website that I normally goto. I run CCleaner everynight so this was a fresh start. The website loaded fine. The page loading icon in Chrome disappeared really quick. Not any advertisements on this site. Went back an hour later but also ran ccleaner to test and once again loaded fast and fine. Tried again 10 minutes later also after ccleaner and the website wasn’t loading so i had to click the back arrow. I let it sit for about 20 seconds. I then clicked the forward arrow and it loaded but the loading icon did not ever go away. The website was appearing ok. It was as if it was trying to resolve lost packets or something. Same thing happens on phones and tablets.

Update Here are the results of an external mtu test i had just completed. It appears it is 1428 so command prompt is incorrect on that. Now that does not help me narrow down what I believe to be packet loss.

« SpeedGuide.net TCP Analyzer Results »
Tested on: 2016.11.10 09:59
IP address: 70.209.xx.xxx
Client OS/browser: Windows 10 (Chrome 54.0.2840.71)

TCP options string: 0204056c0103030801010402
MSS: 1388
MTU: 1428
TCP Window: 16384 (NOT multiple of MSS)
RWIN Scaling: 8 bits (2^8=256)
Unscaled RWIN : 64
Recommended RWINs: 63848, 127696, 255392, 510784, 1021568
BDP limit (200ms): 655kbps (82KBytes/s)
BDP limit (500ms): 262kbps (33KBytes/s)
MTU Discovery: ON
TTL: 113
Timestamps: OFF
SACKs: ON
IP ToS: 00000000 (0)


#2

Hi,

May i know what is the firmware version running for your SOTG device ? Invalid MTU size should not cause the MTU ping test having 75% lost.

Can you please open a support ticket here for us to further check ?

Thank You


#3

I have opened a support ticket. The latest firmware.


#4

Hi,

We will followup with you using support ticket.

Thank You