[SOLVED] Surf SOHO with Pi-hole: Not working as DNS server


#1

I have a Pi-hole installation on one of my Raspberry Pi Model 1Bs. I was able to configure my past router to use it as a DNS server but am unable to figure out how to do so with my new Surf SOHO MK3. I’ve tried changing the DNS server on the WAN and LAN entries inside the Web Admin and by setting it manually on my computer.

The SOHO’s IP is 192.168.1.1 and the Pi-hole’s IP is 192.168.1.33 (set as static). The Pi-hole is connected to the SOHO via ethernet. The Pi-hole can definitely access the internet. I am running the latest firmware revision (v7) on the SOHO.

Any ideas? Thanks in advance.


#2

Hi. We have two similar installations – Balance routers working with PiHole. They work perfectly. I can’t see why it would not work with a SOHO.

Try this: On the SOHO go to Dashboard | WAN Connection Details and select your Priority 1 WAN by hitting the Details button. In DNS Servers specify that Server 1 is 192.168.1.33. I usually set Server 2 to be my preferred upstream DNS, usually OpenDNS.

After doing so, go to a client computer and reset your ethernet adapter or otherwise cause DHCP to “work” again. You’ll see the new primary DNS to be 192.168.1.33.

Now, if I understood you correctly, that you tried to set 192.168.1.33 as DNS directly on a LAN client and that did not work, that’s a different issue – certainly not related to the router. Regardless, be certain to “recycle” your adapter after making any changes.

Rick


#3

Hello Rick,

I’ve tried doing that in many different ways: With and without the “Obtain DNS server address automatically” box checked, with 192.168.1.33 as the lone DNS, and with 192.168.1.33 and 8.8.8.8 as my DNS servers. If I have the first box checked and/or have 8.8.8.8 as an active DNS server, the connection works but the lookups are not being routed to the Pi-hole. If I just have 192.168.1.33 as the only DNS server, WAN SmartCheck fails and there is zero connectivity.

Here is a screenshot of my settings as you asked me to try.


#4

I found a workaround to make the Pi-hole filter the entire network. I connected the Pi via wifi to the ZTE Pocket Wifi (my WAN connection) and put the PI’s IP address as the DNS server on the Pocket Wifi. This works with the “Obtain DNS server automatically” box checked on my WAN.

I still would prefer the SOHO to utilize the Pi-hole without this workaround, but I’ll take it if that’s my only option.


#5

Disclaimer - I do not own a SOHO. I do have other Peplink products and a decent understanding of network principles. If I am off base, someone please enlighten me.

Assumptions - your LAN is setup with your router at 192.168.1.1 and a subnet mask of 255.255.255.0.

You aren’t using the DHCP proxy option are you? If it is enabled, then the router is “capturing” any outbound DNS requests and trying to send them out to the WAN to a non-routeable IP. If you want to use a local DNS server, you should put 192.168.1.33 in your DHCP server settings for DNS server. You can use the router IP as the secondary DNS.

Any client that pulls a DHCP address from the router in the 192.168.1.0/24 network (assumption) will begin sending DNS requests to the local DNS server. The DNS settings on the WAN should point to DNS servers on the internet. You should at least try your ISPs DNS servers before jumping straight to google public DNS. Local ISPs often have more efficient paths to resources.

I would bet that you have a circular DNS loop created. An invalid DNS server configured on the WAN means that nothing (including your local DNS server) can get DNS requests to go anywhere useful. I would imagine your local DNS server was timing out and passing the timeout on to your clients (the one you had statically assigned an IP and DNS server). That, or your static IP on the local DNS isn’t inside the local LAN boundaries.

Give it a shot and post back what you find. You really shouldn’t have to put your local DNS server on the internet to get to it from your LAN. You lose any advantage to having a local DNS.


#6

I did have the DNS proxy enabled in the LAN/Network settings page. I unchecked that and put in 192.168.1.33 as the sole DNS provider on that page. After enabling the settings and renewing the DHCP lease on my computer, the Pi-Hole is working as it should. If I change the DNS server on the WAN connection/details page, DNS resolving no longer works.

Thanks for all of your help!


#7

Glad you got it working. :+1:


#8

I have been running a PiHole as our DNS server for over a year now. I recommend adding the IP of your Surf SOHO as the second DNS server. Should your RPi go offline, clients on your network will still be able to resolve DNS using the SOHO’s DNS server.


#9

Yeah, this is a great idea and I’ve done so. Thanks!


#10

Hi. I’ve been traveling for a couple of days and I now see that you got it working. Great! Looks like JMJONES made the point that got you moving. :grinning: Good news.

FWIW, we’ve found the piHole throws very roughly 22-25% of the DNS inquiries in the bit bucket. Depends on the network and the traffic profile, of course – we have one where it is only around 3-4% because of the type of traffic involved.) Huge decrease in 4G traffic - -a real $$ saver. :+1: