SohoSurf and Frimware 8.1.1

First, I have been using peplink for about 4 years now, and the product is simply outstanding.
I have noticed on the latest firmware routing issues. A few websites do not work, was not showing up. Certain websites the continue or submit button was not working. Go back to 8.1.0 and everything works great. Now for the wild goose chase, I connected onto my cell phone hotspot to diagnose why it was not working and it did not work there either. So, thought screenconnect was down. Tried it on a friends PC and it was working fine.( different household) Turns out that my cell was passing IP6 to the laptop and screenconnect would not resolve on this. turn off ip6 on my laptop, and it works directly connected to the phone. Soo, checking into the cogeco modem and noticed it was in router modeā€¦ so fixed this issue back to bridgemode. Still no luck getting the sohosurf to connect. Also noticed all other websites being a bit slower.

As soon as I go back to 8.1.0 everything works perfect. Internet is snappy again, things are running perfectly.

So, this is a FYI for anyone else who might is having a similar issue/s.

Steam friends list not working either on 8.1.1 but good on 8.1.0
Ontario parks camping website, not working proper on 8.1.1 but ok on 8.1.0

Hope this helps someone else.