SOHO Router VPN via RDP freezes

Morning All !

Pepwave Surf SOHO MK3
8.1.3 build 5030
174 days 0 hours 5 minutes
CPU Load: 73%
Throughput: 1.44 Mbps 6.51 Mbps

Most of the time on a VPN connection , RDP to a client SOHO MK3 router ( Comcast 300 up 35 down ) the data connection works fine as I can download and upload all day with no issues .
RDP on a windows 10 Pro IBUYPower pc for video streaming every so often freezes as I have to disconnect and restart RDP
Windows 10 Enterprise to the Latest upgrade as well as RDP settings changed to use UDP only per instructions from Microsoft and still freezes .
Sitting here watching it it seems the router goes up to 83% and higher . I disconnected RDP but not much of a difference as it went to 63% noting the data streams still worked fine .
Disconnecting RDP and watching my YouTube stream it always works great with no issues so it IS related to only RDP !
Task Mgr shows 51% memory sometimes higher but mostly around that as I shut down browsers and all other non essential services but still freezes pointing back to rdp again .
Locally onsite there is no issue at all running this on the router as the CPU randomly goes to 85% but works fine !
I have 3 SSID’s on the router locally as very few clients with 2 switches 1 - 24 TPLink POE for cameras with 3 POE cameras and the other a cheap Netgear 8 port
with 2 AP’s with 2 SSID’s each and everything works fantastic except for the remote RDP connection thru the Peplink router !
Also over the VPN from my house to the router which is interesting I just ran and came up with 9.6 down and 6.5 up … Isn’t the connection 20 Meg ?

Anyone ever see this as my next step is to do a trace and see what the heaven as well as Windows logging But I can guarantee its the Peplink router …

Thx Everyone !

Is this a new issue and it worked before without issue?

Streaming video over RDP can’t be ideal… what is your use case?