SOHO MK3 Ethernet Speed Issues


#1

I am having LAN speed issues on my SOHO MK3 (firmware 7.1.0 build 1284). WiFi seems to be fine.

I have a 200 Mbps plan using Spectrum. I am getting 206 Mbps when connecting my desktop directly to the cable modem (over Ethernet), bypassing the Soho. When I connect my desktop computer to the Soho (over Ethernet) and the Soho to my cable modem, my speed drops to 46 Mbps. (Using Spectrum’s speed test on their site.)

My WiFi speed is acceptable - 81 Mbps with my phone sitting next to the Soho. Would be nice if I could juice that a bit to the 100 or 120 Mbps limit of the Soho, but I’ll take 81 over 46 for now.

I must have something mis-configured in my router configuration. I have tried changing the Port Speed from Auto to “1000Mbps Full Duplex” under the WAN connection details, and also tried changing MTU from the default of “Custom 1440” to Auto, with no change in speed. My WAN Connection upload and download bandwidth settings are both a 1 Gbps.

Any ideas?


#2

Hello Mike1,

Are you using 2.4Ghz or 5Ghz for your Wifi connection? If you are using 2.4Ghz and your phone supports 5Ghz, I would recommend changing the setting on the SOHO MK3 to prefer 5Ghz.

If the area around you is congested with other Wifi access points, this could also cause issues with your wifi speeds. I would recommend doing a scan and see if you can find a channel that’s less congested.


#3

Hi Mike
When you are testing connected direct to the Spectrum modem, is that the only device connected to the modem? (i.e. Surf SOHO disconnected)
When you test connected to the ethernet on the SOHO, is the testing device the only device connected & creating traffic?
when you do a test have a look at the “Real Time Throughput Graph” on the status page of the Surf SOHO and make sure that the results you are getting from the SpeedTest are similar to what is actually going through the Surf SOHO.
Do you have the Spectrum modem set up in “Bridge Mode” (sometimes known and “dumb mode”)
Having the spectrum modem in Bridge Mode will mean that the Surf SOHO gets your public IP address and there won’t be a double NAT situation which can sometime cause speed limit issues


#4

@GNO-2014: Thank you for your suggestions. Answers below:

  1. When I tested yesterday, I had the Surf SOHO connected to the Spectrum modem, and my desktop computer connected to another port on the Spectrum modem. Today, I disconnected the Surf SOHO from the Spectrum modem, disabled bridge mode on the modem, and connected my computer via Ethernet to port 1 on the modem. I re-ran the Spectrum speed test once assigned an IP from Spectrum, and got 252 Mbps down. That tells me, I think, that the Spectrum modem is not the issue, unless putting it in bridge mode somehow significantly throttles the speed (which I would not expect to be the case).

Reconnecting the Surf SOHO to the modem, re-enabling bridge mode on the modem, and connecting my computer back to the Surf SOHO LAN port, I re-ran the speed test and got 40 Mpbs down again. Nothing else was connected to any of the other Surf SOHO ports. Also, nothing was running on WiFi at the time - not sure if that would impact the wired throughput or not, but I made sure nothing was running (no Roku streaming, no phone or tablet downloads or games being played online, etc.)

  1. I watched the SOHO’s Real Time Throughput Graph while testing with the SOHO reconnected as noted above, and it matched pretty close to the speed Spectrum reported, showing 41-42 Mpbs down while Spectrum reported 40 Mbps.

  2. I do have the Spectrum modem set up in bridge mode so that it acts as a dumb terminal. The modem is capable of 1 Gbps max throughput per the admin interface.

Any additional thoughts? Thanks!


#5

@Zach_Tangen, thanks for your reply.

I am having trouble on the wired side, not wireless, but your suggestion to switch to the 5 Ghz band is a good one to see if I can increase my ~80 Mbps throughput on the wireless side up to 100-120. Once I solve the wired side issue, I will give this a try.


#6

@Mike1,
After reading the post again I misread it originally. Are all of the devices on the LAN having the same speed results? If it’s only one device, can you check to make sure that it’s also connecting at 1000Mbps?

What’s the make and model of the Spectrum modem? It might be worth checking to see if anyone else has had a problem with bridge mode.


#7

@Zach_Tangen,
There is only one device on the LAN - my desktop computer. I have tried switching it out with two other computers and when I plug those in via Ethernet to the back of the Soho, I get the same speed - ~40 Mbps.

Incidentally, when I connected my desktop computer via WiFi instead of Ethernet, I got ~80 Mbps. So, my thinking is that it is something with the Soho router (likely a misconfiguration on my end) and not the computer. I prefer to connect my computer via Ethernet to avoid WiFi interruption.

The Spectrum modem is a Technicolor MediaAccess TC8717T. I get 80 Mbps wireless through the Soho with my wireless devices, so I do not believe it is the modem. And, when I bypass the router and connect my computer directly to the modem (after taking the modem out of bridge mode), I get 206 Mbps.

Lastly, I thought it might be the Ethernet cable, but I used the same cable connecting directly to the modem where I got the 206 Mbps.


#8

@Mike1

This is rather strange. WIFI AP have better performance compare to the Ethernet LAN for he same Ethernet WAN connection.

Please open a support ticket to allow support team to further check from the device.

https://contact.peplink.com/secure/create-support-ticket.html