SOHO Firmware Upgrade-"Invalid Firmware Image"

Trying to upgrade 7.0.0 firmware to 7.0.1 and all I get is this…any guidance on how to fix?

7.0.1 is a number of versions old but if that’s the version you want I’d download it from here. Then just do a manual update.

Yes, Rick, I realize I’m several updates behind, and I understand I need to update them consecutively in order to get to the current 8-series firmware. I have downloaded the first of 10 files directly off the Peplink site, beginning with the one shown below, (copy of file name only) but I continue to get the “invalid firmware image” error message with each one. Is this in the proper format, coming directly off the website? What am I doing wrong? Thanks…

OK. A couple of things. First make certain you are downloading the image for the exact model of the product you have. There have been three versions of the SOHO – HW1, HW2 and the current product, the Mk 3. My best guess is that’s the issue. But I’ll also point out that if you want to upgrade to the current FW you can go directly to 7.1.2 and then to 8.something. You don’t have to take each step in between. Is that helpful?

1 Like

That did it! Not sure where I got those updates from, but I did find the MK3 updates and all is fine, except…I wonder why I have to disable “health check” in the DNS section to make it work?

Excellent! But I’m not sure where you “are” in the GUI vis-a-vis your last comment. Are you here …?

If so, with a SOHO with a single WAN connected, you can very reasonably disable health checks as they serve no purpose. Make sense?

Yes, that’s it. Never had to check “Disable Health Check” before, so though it was something else going on. Thanks for your help…I’ll just run “Without a mask” :wink:

Pretty funny. :grinning: Actually, in a single WAN environment you have lost nothing if you disable health checks. We’d normally disable it. (In a multi-WAN situation they’re vital, however.)

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.