SOHO client certificate error after Reset

I have been unable to access my router admin page due to an error with my client certificate. It’s been just over a year since I set it up to require a client cert, and I didn’t notice that the cert had expired. After futzing with it a while, I decided to just reset the router (using the button) and restore my last backup. But after using the reset button, I still get the same connection problem (the browser output is provided below). If this was a server cert error, I could ignore and continue, but a client cert is a different issue (as it should be).

Does the reset button not clear out the certificate configuration? If so, this thing is now a useless brick (which would suck).
Or is there maybe a default client cert as of some past firmware update that I didn’t notice?

Any suggestions for how to fix or get around this? Any help would be appreciated.

This site can’t provide a secure connection didn’t accept your login certificate, or one may not have been provided.
Try contacting the system admin.

Hi Rick,
Try connecting to the router via a LAN port with an ethernet cable. I think that will bypass the certificate problem.

Sounds like a great idea, but it didn’t work. Same problem. But thanks for the suggestion.

I have similar problems when connecting with a browser; however, chrome and firefox will let you connect anyway if you scroll down to the bottom of page and click on something like advanced options. If this doesn’t work, someone else will have to chime in. Good luck.

I’m afraid that doesn’t work. It’s not just that the server cert that is failing (although that probably also has a problem). This error (ERR_BAD_SSL_CLIENT_AUTH_CERT) is saying that my client certificate is invalid or missing. I expected that resetting the router would cause it to forget it was configured to require a client certificate, but it appears to remember, which implies it didn’t do a full reset after all.

Did you try using a different client device, maybe like your phone (which should have a valid client certificate)? This is just a guess.

If your device is under warranty, you can login to InControl2 and access the Remote Web Admin option. That would be the easiest way to gain access back to your system, and remove the certificate.

Have you tried going to from your mobile phone in the web browser there or any other web browser besides the original one?

Otherwise the error " ERR_BAD_SSL_CLIENT_AUTH_CERT" is usually associated with a browser problem or time issue on the device you are using. A quick google search has multiple ways to potentially fix the issue. Try Ctrl+F5 for a webpage force reload in the browser, but otherwise here is the link to some other suggestions. How to Fix ERR_BAD_SSL_CLIENT_AUTH_CERT for Google Chrome?

It’s always the obvious things, isn’t it? I had meant to try it from another device, and forgot about that. I don’t know why, but it worked from my phone when it failed from my laptop.

When I restored my configuration, it went back to the same problem. However, I did reset and started over yet again, but this time upgraded my firmware to the latest (which also updates the server certificate, if I’m not mistaken). After that, everything worked perfectly.

I plan to cycle the router a couple times and make sure everything is solid, but it looks good so far. Thanks to everybody for the help. I wasn’t expecting such quick responses, but you guys are great.

Thanks again!

1 Like