Soho 6.0.3 and Arris modem SB6121 disconnecting internet


#1

Hello, been using my older peplink Soho in combo with Motorola SB6121 for years with Cox cable but last night and this morning lost the internet connect as long as I use the Soho. Several resets of modem and soho still did not solve. There is internet, but only if I connect my computer to the modem directly only and bypass the Soho (not good, it takes away all the wifi as well as other connected devices of laptop and phone).

(I earlier looked and did not think I could upgrade the firmware from 6.0.3 on my unit… and Cox tech did verify it was the Soho link not working, that internet is going to the modem, and yes, bypassing Soho, the internet does work)

Would be grateful for any help to fix this?

many thanks!


#2

Hi IPS. You may wish to take note of the many messages exchanged in this forum regarding issues with Arris/Motorola 6121, 6141 (etc) modems. Others have found precisely what you have – there appears to be a “communication issue” between these modems (but not many other Arris/Motorola modems) and certain Peplink routers.
FWIW, we have never been able to resolve this and simply replaced the older modems.
Check out the other threads. :neutral_face:


#3

thank you so much Rick, couldn’t figure out how to search your forum-- any more compatible, newer, non-router-attached modem that would work better with the Peplink? have a good rest of your weekend


#4

figured out the search… read through the posts for the sb6121. One user tried the sb6183 but there was no mention if that solved it. I went to the arris/motorola site and the sb6190 seemed well reviewed (for other things, not for the SoHo). What are your thoughts for this one? Also is my SoHo able to have a firmware update from the 6.0.3 that could help? anyway, a thousand thanks for the input, getting another modem would be simpler


#5

Hi. I am not sure a FW upgrade to your Peplink device will help – although you may want to upgrade for other reasons. What I can tell you is that we have the following modems in use that do seem to play nicely with Peplink SOHO and Balance routers:

  • Arris 6183
  • Arris CM820A
  • Technicolor (unknown model # - furnished by Spectrum/T-W - it’s about 800 miles away from me as I write this and I can’t exactly check)

One trick you may want to try: If you have a small switch laying around unused place it between modem and router. It’s a cobble-job but it sometimes works; often not.

Rick


#6

Good morning Rick, no switch :-(… but I’ll give the 6183 a try. (After reading more reviews on the 6190 it was having disconnect problems with others systems (nonPeplink) and don’t really need the other features of the 8200), but thank you so much for letting me know what has worked with yours and the on-going of this, so very much appreciate your time, have a nice Sunday!


#7

6183 is solid in my experience. 6190 uses the buggy Intel Puma chipset which has a ton of issues.


#8

excellent-- thank you for verifying that!, yes, that is what I had read!