Slow internet - Peplink Balance 20


#1

Hello,

Recently purchased Peplink Balance 20 Router. I have DLS service with ATT using Motorola NVG510 (Modem/Router). Download speed I’m getting via Peplink Balance 20 Router is 2.0 mbps. Actual download speed is 3.0mbps. I searched this forum and did not find any solutions to slow download speed issue. If I connect PC directly to the modem speed is 3+ mbps. Anyone has any advice how to fix this issue? Also if you need any more details about my setup let me know.

Thanks,


#2

Hi,

  1. How many WAN link you have?

  2. Can you share the Outbound Policy if you have more than 1 WAN link.

  3. Please upgrade to latest firmware version if you tested with old firmware.

  4. Your laptop connected directly to B20’s LAN port when you do the test?

  5. Have you enable Individual Bandwidth Limit (Network > Bandwidth Control > Individual Bandwidth Limit)?


#3
  1. I have 1 WAN link.
  2. I did not make any changes in Outbound Policy (Default Setting)
  3. I just bought B20, it already has latest firmware.
  4. Yes my PC was directly connected to LAN port when I tested.
  5. Did not make changes under Individual Bandwidth Limit (Default setting)

#4

Hi,

Try to fix the port speed and duplex mode (Network > WAN > Select WAN > Physical Interface Settings) for WAN interface of B20 and modem to confirm this will help. Do let me know the result.

Thank you.


#5

Thanks!
What’s the recommended setting for Physical Interface Settings > Speed?
Currently, mine is set to AUTO.


#6

AUTO generally works fine but some modems are picky. You should try 100M FD. You can also check your MTU setting as with DSL it should be set to 1492.


#7

I’m having this same issue, using a Peplink 305 running 6.2.2 just installed this with new carrier 100mb circuit. Setup is ASA firewall connected to Peplink LAN port. Peplink WAN 1 is directly connected to carrier router. When laptop is directly connected to inside interface of ASA and the rest of configuration is as described above download and upload speeds are between 55 and 65mb. When I remove the Peplink and directly connect the ASA to the carrier router the down and up speeds are 92mb. Obviously the laptop, ASA, and carrier router are not the issue as this bandwidth degradation on occurs when the Peplink is in the mix. At this time I only have the one carrier connected and I used Drop in mode on the Peplink. The WAN 1 interface is set to Auto/Auto which is the only way it will connect to the carrier router and the bw is set to 100down and 100 up. I’ve tried to look via the CLI but so far have not found a way to look at the Peplink interfaces to see how they are actually running or if there are any errors. I too made no changes to the outbound policies or bandwidth limits.

Any thoughts would be appreciated.


#8

Hi,

As mentioned above, please help to fix the port speed and duplex mode for ASA (WAN port), B305 (LAN and WAN ports), modem (LAN port) to confirm this will help. If you still facing problem, please help to open ticket for us to take closer look.

Thank you.


#9

Thank you for the reply, as I mentioned adjusting the ASA WAN ports has already been tried. What I’m having difficulties with is finding where I would change the Peplink port speeds or at least see what they are currently set to and how they are preforming. There is no modem in the mix this is a 100mb Ethernet circuit with a provider supplied router. When the ASA is directly connected to the provider router and my laptop is connected to the ASA I get 92+mb, it’s when the Peplink is installed between the ASA and provider router that we lose 25mb of bandwidth. I have not found a way to look at the interfaces on the Peplink which is the problem.


#10

There is a hidden support page you can access here:
theipofyourbalance/cgi-bin/MANGA/support.cgi


#11

Thanks, but I can’t reach that link


#12

After logging into the Balance, type this URL in your browser to get to the page:

http://<Your device’s IP>/cgi-bin/MANGA/support.cgi


#13

So the default would be http://192.168.1.1/cgi-bin/MANGA/support.cgi

But your IP may be different so you would replace the 192.168.1.1 to whatever your Balance router IP address is.