Slow 2.4ghz wifi on Surf

Mk3 Surf SOHO Firware 8.1.0 build 4941
I’ve had a problem with slowness on 2.4ghz wifi on my old android tablet, but I always thought it was the android version or something.
But I got a new Android (9.0) tablet that unfortunately only supports 2.4ghz wifi.
new tablet : .49 mb/s (yes, that’s a point 49)
Google Pixel 3 on 5ghz wifi: 81 mb/s
Laptop on 5ghz: 79 mb/s
new tablet using the pixel 3 as a hotspot: 12 mb/s

I’ve tried to set the 2.4ghz settings to speed it up, but nothing has helped. It’s on ch 11, auto channel width, created new SSID. Even updated firmware from 8.0.6 to 8.1.0. Nothing has helped.
How do I get this fixed?

The 2.4GHz wifi band is notorious for interference from home appliances and neighbors. I would try an ethernet cable connection between the router and the tablet to see if that helps.

It’s an android tablet, so no ethernet jack. But the tablet is much faster if I use a hotspot. I’m going to test at the public library today and see what the speeds are.

You can use an ethernet-USB converter; I’ve seen some fairly inexpensive ones.

Agree with rmrcu10. Take a look at what the RSSI is for your 2.4 GHz environment, and also specifically what your noise floor is. 2.4 GHz is really noisy.

Download an app from the Play Store called “Aruba Utilities”. It will give you the data you need to see what the quality of the 2.4 GHz environment you’re testing in really is.

I took the tablet to the public library. Connected fine, 20 mb/s download. Connected to CoxWIFI at a local hotspot. Connected fine, 15 mb/s.
Came home and started testing. Every wifi around me is at least 30db lower than mine.I went through each channel, and the only one that reliably worked for me is ch1 with auto channel width. Every other combination was slow.
Why does this affect android tablets and not wii, Integra receiver or my ancient HP touchpad?

Sounds like you’ve made progress–now you can get decent wifi speed from channel 1.

Remember, not everything working on 2.4 GHz is Wifi. What is the RSSI of your SSID?

-38 db while in the same room as the router, -45 while sitting 30ft away. All other SSIDs wifi analyzer can see are -70 or lower.

Tonight my main laptop (which usually picks 5ghz) associated to 2.4ghz and I’m seeing the same problems my two android tablets are seeing. The AP is still on channel 1. All other SSIDs I can see are -70 to -90 db. The only other chan 1 SSID is somebody’s printer at -85 db.
At my mom’s house I connected the android tablet to her tp-link router at 2.4ghz and had zero problems. So that’s three separate wifi networks that it works on, but not my own. Definitely something funky with the peplink router.

Hello @john_schoenstein,

try this…

  1. set the bandwidth to 20MHz, 40MHz tops. and on a channel that is no or least overlap with adjacent carriers.
  2. download (assuming your laptop is Win10) WinFi Lite (
    This will give you a good look on all the Wifi in the area and their performance.
    incl. Min/Max rate your wifi link should give and which 802.11amendment are running.

One thing you need to keep in mind is that you only see Wifi on these analysers, but 2.4GHz is a free for all, meaning if you have a baby monitor, security camera, or any other wireless device not using wifi, there is a high chance that it can interfere.


I see about 60+ networks from my main floor… close to 100 on 2nd floor.

Here’s a view from main floor:

I set my channel width to 20 and reduced my tx power a little to a point where i still get decent signal.

Sadly, most people don’t bother or know how to tweak their wifi, so running defaults, which is usually max tx power and widest channel, hence the saturation. I only use channels 1, 6 and 11 but it doesnt really matter when you have this many overlapping networks.

That said, I decided to leave 2.4 band for IoT devices and my guest networks… my main devices (iOS, laptops etc) all use 5ghz. 5ghz gives you more channels to play with. I set mine to 20mhz wide which gives channel 165 that no one else uses.

But sadly, most are running 80 mgz wide channels so getting a bit of overlap.

I disabled the 2.4 on my main network, and disabled 5ghz on guest and IoT networks…


FYI… using NetSpot to analyze wifi.


Your debugging steps have been excellent. Clearly the issue is in your home only. So, it could either be the router or radio interference from some other device(s).

The only way to narrow things down is to move the router and test again. Perhaps just to the other side of your home … or another floor … or perhaps even farther away. If you take it to another home, simply connect the WAN port of your router to a LAN port on the existing router. Be sure to test both WiFi frequency bands at every new location.

Then again, has the problem survived a cold boot of the router?

2.4GHz should not default to a wide channel. 5Ghz is different. The Surf SOHO, like most routers, defaults to a narrow 20MHz wide channel on the 2.4GHz band. Still for good luck, I would force this and not leave it set at Automatic.

I too see most 5GHz networks using very wide channels. In a crowded WiFi neighborhood this would seem to be a lose-lose situation.

1 Like

I borrowed my mom’s router (sorry mom!), unplugged my pepwave and pluged her router into my modem. It picked channel 6, is 40DB above any other wifi signal in the area…


My 2.4ghz devices connected Just Fine. I got 39mb download speed with the router sitting in the same place the Pepwave does, and me sitting on the same spot on the couch I always sit.
So it’s not the environment, it’s the device. Either there’s a problem with the code in the router or the 2.4ghz radio is having problems. So either I need to buy a new pepwave surf so I can keep my configuration, or I shop around with a router with 802.1q support.
Now to return my mom’s router so that she can watch Netflix tonight…

John: I hate to nit-pick but local radio interference comes and goes. Using another router in the same spot is not ironclad proof that the router is faulty. Granted it sure looks like the router is at fault, but if you can, test it in another physical location. If it was a problem on all Surf SOHOs with the same firmware, I would expect this forum to flood with unhappy customers.

And, although its a long shot, perhaps backup the system settings, do a factory reset and restore the system settings. Apologies if you tried this already.