SFE and FW 8.1.0 SIM card not Detected

Hi, yesterday I updated one of our test SpeedFusion Engines from 7.1 to 7.1.2 and then to 8.1.0 However after the update the Dashboard showed “No SIM card detected” on both SIMs. A downgrade to 8.0.2 worked, however it shows an alert “Remote SIM Component not supported on this Firmware”.

Any suggestion regarding the 8.1.0 issue?


Please perform the firmware upgrade again from 8.0.2 to 8.1.0 to confirm the alert “Remote SIM Component not supported on this Firmware” still exist.

For the “No SIM card detected”, please click “Reload SIM” to confirm it helps.

1 Like

Yeap, still exist. Was the second thing I tested. From 8.0.2 to 8.1.0 Reload SIM doesn’t help at all.

Are you doing Remote SIM (SpeedFusion Engine + SIM Injector) deployment?

1 Like

No, standard SFE with integrated SIM. However, the SIM card holder are internally on a separated board.

Today I tried again to update another SFE from 7.1.1 step by step to 8.1. Here the results I also postet in a ticket:

  • SFE HW 2 with FW 7.1.2 works as expected
  • With FW 8.0.1 and 8.0.2 shows a warning that Remote SIM card will not work with this hardware, but SIM cards are detected and connected.
  • SFE FW 8.1.0 build 4941 doesn’t show any warning but SIM cards are not detected.
  • Reload SIM doesn’t provide a solution
  • Same situation of two SFEs
  • SFE keep “Resetting” the modems

I’m the only one with two SFE doesn’t work with 8.1.0??

Can you provide a photo to show how this is looked like?

1 Like

That issue is a well know time ago:

Look like you have opened a ticket and our technical support engineer is following up with you. Please help to follow up there since we have more visibility.


1 Like

Yes sure, I’m just updating here as well to keep other members informed. Actually we upgraded the modems firmware and support team fixed an issue on the device through remote assistance. Now it is working. The issue was the SFE was HW2, but an older model. SFE is now running 8.1.1 without errors.

I have encountered an issue with 2 different Max HD2 Mini’s where the device doesn’t detect the SIM card in slot 1. These are devices which have been functioning with no issue and have not been physically touched.

Rebooting the device doesn’t fix the issue, a full power disconnect and reconnect, Reload Sim in webui, etc, also doesn’t have any effect.

The ONLY way to fix it is to physically remove and reinsert the SIM. It is then detected once again.

8.1.0 build 4943

@Sneeze, have you closed the SIM slots with the SIM cover?

1 Like

Yes the SIM slot cover is on, the SIM’s are very snug though and don’t budge on their own. These units have been in position for over 12 months without being touched. They aren’t running 24/7 and are only switched on when required from a central switch controlling power to the entire equipment rack.

One of the units has a second SIM in slot 2 which continued functioning fine. The other unit only had a SIM in slot 1 so lost all connectivity.

@Sneeze, I suspect it is a contact issue between the SIM card and the SIM slot. Please remove the SIM card then clean it to confirm this helps.

May I know this definitely can be reproduced after the HD2 Minis are powered? It always happen to the same SIM slot?

1 Like

@TK_Liew, These SIM cards are quite new and there’s no visible indication that there could be a contact issue requiring cleaning. It has only been seen to occur in SIM slot 1 at the moment. Each occurrence has been resolved by sliding the SIM out and back in whilst the device is powered off.

If it occurred once I could put that down to an anomaly, but seeing it occur exactly the same on two devices is concerning. We will be monitoring all of our HD2 Mini’s for this issue for the time being and will report if we see it again.

Yes, please let us know. If this will happen every time the HD2 Mini is powered on, then it is easier for us to do the investigation.

1 Like

@TK_Liew Had this SIM not detected issue occur again on another MAX HD2. SIM 1 working fine, SIM slot 2 reporting no sim. The Reload SIM function didn’t fix it, power cycling the unit didn’t fix it. The SIM had to be popped out slightly and back in to be detected again.

This unit is in an installation where it can’t be moved or touched accidentally so there’s been no physical disturbance to the SIM.

Firmware is 8.1.3 build 5172.

@TK_Liew I’m seeing this issue again with Max HD2 Mini (8.2.0 build 5312) which has SIM cards installed in both “A” slots. After 6.5 hours of runtime the SIM in Cell 2/A all of a sudden disconnects and reports as not detected in the GUI dashboard. The “Reload Sim” option has no effect.

If I view the Cellular 2 details however I can see Slot A says “(SIM Card Detected) (In Use)” But no details are displayed as far as IMSI, ICCID, Carrier, network, etc. All are correctly displayed and active for the Cellular 1 SIM.

System log displays the following since power on until the problem occurred. The device has not been touched during this time.

Oct 03 13:44:50 WAN: Cellular 2 failed to read SIM A
Oct 03 13:44:12 WAN: Cellular 2 SIM A changed, reloading SIM
Oct 03 13:44:08 WAN: Cellular 2 (Priority 1) disconnected in SIM slot A
Oct 03 13:30:54 WAN: Cellular 2 (Priority 1) connected to OPTUS (xxx.xxx.xxx.xxx) in SIM slot A
Oct 03 13:30:06 WAN: Cellular 2 (Priority 1) disconnected in SIM slot A
Oct 03 13:29:50 WAN: Cellular 2 SIM A changed, reloading SIM
Oct 03 07:00:27 System: Time synchronization successful (xxx.xxx.xxx.xxx)
Oct 03 07:00:22 WAN: Cellular 1 (Priority 1) connected to Telstra (xxx.xxx.xxx.xxx) in SIM slot A
Oct 03 07:00:20 WAN: Cellular 2 (Priority 1) connected to OPTUS (xxx.xxx.xxx) in SIM slot A
Oct 03 06:59:38 System: Started up (8.2.0 build 5312)

Powering off the device and restarting it does not fix the issue.

Oct 03 15:24:50 WAN: Cellular 2 failed to read SIM A
Oct 03 15:24:12 WAN: Cellular 2 detected new SIM A available, reloading SIM

I’m yet to physically remove and re-insert the SIM due to a lack of physical access but historically this gets it working again until it next fails. I’ve experienced this issue with several Max HD2 Mini’s in our fleet.

@Sneeze, do you think you can submit a ticket for the team to take a closer look at the HD2 Mini?

Please quote this forum (link) in the ticket so the support personnel could refer to this thread for some background information.