Setup instructions for router utility app for iOS

I’ve just installed my Peplink MAX Transit Duo. I configured it using my browser. Now I’d like to set up the Router Utlity, however, I can’t get it to connect to the router. When I launch the app, it points me to the add a device screen. From there It looks like the only required field is the host name. I copied the host name from the System > Admin Security screen.

But when I click Save, the save button quickly dims and then lights back up. Nothing else happens. No updates, no errors. It is like the input is being rejected outright. I also tried adding the Device Name, the admin I’d & password.

What am I doing wrong? Is there some other setting that needs to be changed?

Thanks.

Have you tried the serial number?

Hi Danny. Well, that field name may not be too logical. :wink: In “Host Name” insert the IP address of the target router. It’s not the serial number or name of the device. The “Device Name” is just your name or handle for the subject router.

The IP address in the Host field m got the record created, but I can’t get logged in. Am I supposed to used the same admin ID and password that I use to log into the console in the browser?

Try this:

  1. If you are coming in via the WAN side make certain access is authorized via WAN in the Max.
  2. Make certain you specify the port to which you want to connect (80 or 443 if you have not changed the defaults)
  3. Turn on “Secure Connection” if applicable [strongly recommended.]
  4. Username and Password will be as configured in the device and may be either user or admin – your choice.

Comment: We normally allow access only via LAN-side, normally use the user credentials rather than admin, and never use the default ports. Your decisions in those regards.