Setting up l2tp remote access


#1

I followed the guide here:

Seems pretty straightforward but when i attempt this with my android phone (connected to cellular data) it is always unsuccessful. I get no error beyond that. In the peplink event log i see nothing - it does not appear to log any attempt to connect.

Not sure what i can try next - does the fact that i never see anything in the log mean the connection is not getting through? I have 2 public IP’s and the result is the same with both…

I do have the firewall on the peplink enabled - do i need to open ports to get this to work?

Thanks for any advice.


#2

Hi Grahamk:

After a quick test in-house, the inbound firewall shouldn’t stop the connection to the Peplink (all things being equal) but as a down and dirty test, go ahead and turn things off for a moment to test. I suspect you’re still not going to be able to connect up. One thing you mention is that you’re on cell data and I’d want to be sure you’re carrier isn’t blocking ports at all for L2TP which could prevent the connection attempt from making it to the Balance. A quick way to test that, can you get the phone on an external Wi-Fi for example (off local network of course) and see if you get it?

If nothing works, go ahead and open a support ticket with us here and we’ll keep digging.


#3

When you test do you see the incoming connection in the device log? I am seeing nothing, which leads me to wonder if it is being blocked somehow - but I have tried connecting to both my inbound IP’s with the same result and VPN works to other networks…


#4

Once things connect, you should absolutely see things in the client list and flagged as an L2TP connection. I see you got a ticket up and running also and we can keep going over there to get to the bottom of things. Thanks for the follow-up!