Server with static IP behind Peplink Balance 390


#1

Hello
I’m having trouble configuring a server with a static public IP to be accesible through a peplink balance 390 and was wondering if anyone could help.

I never had to do this since I usually just configure the nat mapping to do a 1 on 1 and had no problems accessing the server but that left the server with a dhcp ip thats not public and I need to try out an app on a server that identifies its IP from the network adapters. Doing that left me with the app that communicates to other servers successfully but cannot be reached since it is reporting its ip to be the internal dhcp ip.

So far what I did was, configure the server with the static public ip which at the same time is configured in the list of available ips on the peplink. Then I made a server with that ip in the inbound access section. Then I setup a service in the same section to make sure all TCP traffic to the static public ip is directed to the server. But when trying to connect I get connection refused.

I know I must be missing something very stupid but I looked on the net and didn’t find any guide on doing it and I just can’t figure it out.

So any help would be greatly appreciated.

Thanks.


#2

Hi,

First of all, you should either configure a static IP or configure DHCP reservation under the LAN setting (as per below screenshot) for the server.


Once you have got the fixed IP address, you can configure a one to one NAT. You define the additional public IP under the WAN interface setting as per below screenshot.


Then you define the one to one NAT under NAT Mappings as per below screenshot.


The server now should be able accessible internally and externally via public.

Thanks,
Stanley


#3

Hello Stanley,
Thank you very much for your help. That is exactly what I usually do, unfortunately, the static ip I’m able to configure through the DHCP server settings under LAN is not a public ip, which in turn means that the server does not have a public ip configured in its network interfaces. That there is my problem, the app I’m running can only define its ip address from its network interfaces so when trying to communicate aboard its asking other servers on the internet to reply to the ip 10.10.10.100(as for your example) instead of its public ip 192.168.52.100(as for your example) and therefore communication only occurs one way since the reply messages fail to be delivered. This is obviously a problem with the app but fixing it is apparently not that easy and I’m looking for a solution around the problem that doesn’t involve removing the server from the peplink and connecting it on a switch. Any ideas?

Thanks again


#4

In that case, the application will not work unless it is holding an Public IP address without NAT. It looks like it is an application limitation which should be fixed to get it works.