Routing SIP traffic


#1

I have a Peplink Balance 580 and hosted VOIP (VirtualPBX) that the router correctly identifies as SIP.

I have 3 cable lines and 1 T1. I want all SIP traffic routed through the T1, with failover to one of the cables. I want all other traffic routed through the cables.

I initially set up Outbound rules, using Priority, to achieve this, and it seems to work most of the time but not all of the time, and lately it seems to fail more often. I changed the Rules not long ago to use the phone’s MAC address instead of IP address and I now wonder if that’s why I’m having more trouble.

Is there another way, a better way?

Also, using Priority Outbound rules worked fairly well as long as all devices had a rule. When a new device was added to the network, or we have a customer in house (rare but it happens) with a cell phone, they inevitably end up on my T1 causing my voice traffic to bog down. What’s the best way to prevent this?

Thanks for any suggestions!


#2

Hi,

Outbound policy with IP address should work well for your case. Can you share us the defined outbound policy (Overall defined rules & detail SIP traffic outbound policy) for us to further check ?

Beside that, can you let us know how the new device or customer in house connected to the network ? Are they running using the same IP network with the staff ?

Thank You


#3

I would dedicate a VLAN just for your Voice network and make your first outbound policy: source the voice network, destination the trusted host network(s) and protocol UDP or TCP depending on your platform, then just make ANY port, make your algorithm priority with whatever circuits you want first or possibly overflow depending on the amount of devices you have on your Voice network and the amount of bandwidth for the circuits. You don’t want to load balance voice traffic from my experience just because of source and destination port issues and hopping that can happen after you have already established a call. If you load balance in the middle of a call you will probably get one way audio or you phones won’t register correctly.


#4


I’ve attached a screenshot of one of the outbound rules for the phones. WAN4 is the T1. 1, 2, and 3 are the cable lines. The others are not in use.

Guests connect on the same lan. The router is the dhcp server.

Although I do my best to manage this network, I am definitely nowhere near being a network engineer… I learn what I need as I go… network stuff makes my head hurt lol. If you could point me to a guide on how to separate the voice traffic and the guest traffic that would be awesome.

Thank you both for responding and trying to help!


#5

Believe this is the connectivity:-

IP phones —> Switch —> Balance 580 (WAN1, 2, 3) —> Internet

Requirement

  1. Ensure you have latest firmware for Balance 580.

  2. Ensure you are using managed switch (configurable switch which supports Vlan)

Steps to separate voice and data by Vlan:

  1. Create new Vlan at Balance 580
    http://www.peplink.com/knowledgebase/how-to-enable-vlan-trunk-setting/

Example screenshot


  1. Create Vlan in switch
  • Create new Vlan (eg. Vlan 2) in switch.
  1. Enable trunk on the switch ports that connected to Balance 580 and AP (if applicable)

  2. Assign Vlan 2 to the switch ports that connected to IP phones.

Hope this help.


#6

Thank you for the info on setting up a vlan. I plan to do that this weekend… meanwhile, something just occurred to me and I checked my T1 settings and I think this is a problem, but I don’t know enough to be sure.

The T1 is 1.5mb total (up/down) yet for some reason I set it up and 1.5 up and 1.5 down. I should cut that in half, right? SIP calls use about the same up and down? I think this may be part of my problem - I’m ok with SIP traffic rolling over to the cable lines when necessary.



#7

Hi KathyS, you should leave the up/down settings as is because that is the speed of the T1. Thanks.