Roaming between multiple APs (AP One Enterprise) on a single network

I have 3 APO-ENT devices on a single network, each on separate channels. I can roam from one to the other seamlessly on my Android phone, but even setting my Windows 10 laptop’s Wi-Fi card roaming aggressiveness to “highest”, the PC hangs on to the initial AP despite the signal almost disappearing, and the laptop sitting right next to one of the other APs.
I have the APs managed by a Balance One.

1 Like

You could try to turn down the power a notch on the 3 AP’s and see how that works. I also recommend to disable any power saving functionality on the laptop Wi-Fi card.


I’ve used both Fixed:Max and Dynamic:Auto - no difference.
Why would the laptop network card power management setting make any difference? WiFi was in use the whole time I was testing going from AP to AP.

1 Like

Roaming decision is generally the responsibility of the wireless client device. Do you have the latest network driver installed for your laptop WIFI card ? Worry it may be related to the WIFI card diver issue.


Yes, I do. Nov’16. Relatively new Samsung notebook with all updates from Samsung Update software applied.

1 Like

Using a Wifi AP Controller will do this much better but they are expensive.
I don’t know if Pep-link makes a product for this.
I use Ubiquiti APs. The Pro stuff doesn’t require a separate controller . They come with a central management
software that works. I have used it to mesh dozens of AP’s and it works flawlessly.

1 Like

We are trying to offer one of our five star resort hotel with almost 100 AP one / one mini. The big issue is the same as @lwollen. An exactly @wsabee said about Ubiquiti and Ruckus. They have a feature on their controller to force wifi client to associated with better signal. Just wonder will we have this feather ?

1 Like

I’m seeing this same behaviour on a newer Dell Windows 10 laptop.

Testing between an AP mini and B20x. I have set the client threshold on the AP mini to -65… which seems to work, as it disconnects my laptop… but then it doesnt reconnect to my B20x AP.

I have to manually reconnect to the network, even when back in range of the AP mini.

I have enabled “Fast Transition” for the AP SSIDs…

Running on latest firmare for both the b20x and ap mini.

I have adjusted the laptop wireless adapter roaming agressiveness from medium to medium high and set preferred band to 5ghz as well as preventing power management from shutting off the wlan adapter to save power.

We’ll see if that helps.