Reduce network/TCP buffer size: internet is designed for 100 msec buffers not 4200 ms


#1

Network buffer measurements with a BA310 HW version 2: Uplink 4200 ms, Downlink 3100 ms by http://n1.netalyzr.icsi.berkeley.edu/

We estimate your uplink as having 4200 msec of buffering. This is quite high, and you may experience substantial disruption to your network performance when performing interactive tasks such as web-surfing while simultaneously conducting large uploads. With such a buffer, real-time applications such as games or audio chat can work quite poorly when conducting large uploads at the same time.

We estimate your downlink as having 3100 msec of buffering. This is quite high, and you may experience substantial disruption to your network performance when performing interactive tasks such as web-surfing while simultaneously conducting large downloads. With such a buffer, real-time applications such as games or audio chat can work quite poorly when conducting large downloads at the same time.

Please allow administrator to reduce their network/TCP buffer size on the Balance routers to around 100 milliseconds.


#2

Thanks for your report. The coming firmware 5.4 should have improvement in this aspect.


#3

Could you be a bit more concrete, what improvement(s) should be expected?
F.e. will there be new settings?


#4

Before your post, we found the network buffer size in firmware 5.3 (or 5.4 beta) were unnecessarily large. We have lowered the buffer size in 5.4 RC/GA firmware. No new settings are introduced.

For a Peplink Balance running 5.4 RC firmware, the same test reported 100 ms or even less “buffer time”.


#5

I have a different issue when running those tests: “Netalyzr’s bandwidth test may have disrupted your network. Netalyzr experienced transient difficulties when uploading test results. The most common cause of this problem is poorly designed home network equipment which crashes as a consequence of Netalyzr’s bandwidth test.”

My model 30 does go offline 90 seconds when the download tests commence.

Update: I thought it might be the health check, killing the WAN, but not so. Thats an interesting problem - if you saturate the WAN, the UDP health packets might get dropped too, causing the WAN to be turned off. Yikes.

After several repeat Netalyzr tests on any of the WAN’s, the router does block after the download tests start. Something is going wrong here.

rossh


#6

@rossh: different issues would benefit from opening a new thread.


#7

I’m running 5.4 and using that test I’m seeing excess of 6400ms… when will this be fixed? Why can’t there just be a manual adjustment for the buffersize?


#8

We are working on a firmware which allow users to customize the interface buffer size. We will release the firmware to our beta customers for testing in next week. DeadRinger and anyone who are interested in the trying out, please sign up as a beta tester and let us know you are interested in testing the firmware: http://www.peplink.com/contact/support/ .


#9

I just downloaded and installed version 5.4.7 build 1920 and I still do not see any place where the buffers can be adjusted - furthermore testing is showing that there’s still more than 5,000 msec of buffering in this new version.

is there any detail to this? was this adjustable buffer size feature included in this version?


#10

Changing the WAN buffer is available on firmware 5.4.7. And here is how to do it.

  1. Go to http://<Your Balance or MAX IP Address>/cgi-bin/MANGA/support.cgi
  2. Scroll down the page and enable “WAN Connection Buffer Size”
  3. Set your desired WAN buffer size for each WAN
  4. Hit “Save”
  5. Go to http://<Your Balance or MAX IP Address>/cgi-bin/MANGA/index.cgi and hit “Apply Changes” on top right corner

Feel the difference.

Because this is a pretty advance feature that mis-configuration will severely affect the WAN throughput and latency so we arrange this setting a bit further down the web admin page. Hope it helps.


#11

Awesome - this totally fixed my issue - will this become a more public feature? or will it continue to be hidden in the support menu?


#12

This will stay in the support menu because the average user would probably enter a very high number thinking it will make it go faster :slight_smile:

Glad it fixed your issue…


#13

Touche - ok, well I’m glad I have access to it… thanks guys!


#14

The default in 5.4.7 is 2000 packets. Unfortunately the size can only configured as 1 value for both the download and upload buffer size. We wish 2 different values, 1 for upload and 1 for the download buffer size per WAN link.

Reducing to 50 packets, and pressing [Save] and [Apply Changes], did reduce our buffer size.

from:
We estimate your uplink as having 5900 ms of buffering. This is quite high, and you may experience substantial disruption to your network performance when performing interactive tasks such as web-surfing while simultaneously conducting large uploads. With such a buffer, real-time applications such as games or audio chat can work quite poorly when conducting large uploads at the same time.

to:
We estimate your uplink as having 350 ms of buffering. This level may serve well for maximizing speed while minimizing the impact of large transfers on other traffic.
We were not able to produce enough traffic to load the downlink buffer, or the downlink buffer is particularly small. You probably have excellent behavior when downloading files and attempting to do other tasks.