Red Status blinking light


#1

Hello

I have a Balance 20 router, right now its status light is blinking and red, what does this mean? I can not access the unit. I’ve tried with reset hole in front side and nothing happen. Is there something else that I can do?


#2

Hi arnoldmontiel,

That is definitely weird behavior. If the factory reset did not make a difference in gaining access to the unit go ahead and open a support ticket here and we’ll help out further.


#3

I am also experiencing the same problem on one of my Balance 20 with a custom modem firmware 5.4.7m34-build1683. The first couple of occurrences of the problem, which always happens after a reboot, the router managed to come back online after being disconnected from the network and turned off for a day or so. However, this time I’m afraid that it is not the case. Tried factory reset button which seems to do nothing. Green power LED is on while the status light remains off then eventually starts blinking red and router is unresponsive. Is there another way I can reset the router? Or are we talking about toast? My warranty just expired a few weeks ago, so I’d appreciate any advice I can get.


#4

Please open a support ticket via our website and we will get this taken care of for you.