Question on VLAN with AP AC One Mini


#1

Setting up a new Access Point, AP AC One Mini that is connected to a Surf SOHO. All was well with the default VLAN ID of zero. AP is creating a single SSID. But, I want to isolate users on the AP SSID. Totally isolate them, so they can get to the Internet and not see any other devices.

I did: AP -> My ssid -> default VLAN ID
and set it to a number not used on the Surf SOHO
This caused devices not to be assigned an IP address.

Then I tried a VLAN ID that is defined on the Surf SOHO and the same result, my AP client could not be assigned an IP address.

Do I have to set the AP as the DHCP server? The default for DHCP is off.
Thanks in advance.


#2

Hi Michael,

  1. Will you consider to add addition SSID for Guest (Isolated users)? So, you will have 2 SSIDs. One for Internal user and another for Guest.

  2. The AC Mini directly connected to Surf Soho?

Look like you are setting up single SSID which mixed with Internal users and guests.


#3

TK,

  1. I was starting simple with a single SSID on the Access Point for untrusted IoT devices that I want to isolate as much as possible. Maybe later a second SSID for trusted users, but first things first. No intention to mix internal users and guests on the same SSID. Sorry if that wasn’t clear.

  2. The AC Mini is connected to a switch that is plugged into a LAN port of the Surf SOHO. Not sure if you consider that “directly connected” or not.

My guess is that to assign a VLAN to an SSID created by the AP that there must be a requirement for the AP to act as the DHCP server. No? Or must the AP be in “router” mode rather than the default “bridge” mode?


#4

Hi Michael,

You can configure in this way. I assume you are using managed switch.

Surf Soho

  1. Add IOT Vlan on Surf Soho

  1. Ensure trunk ports was configured on Surf Soho

Switch

  1. Ensure Vlan 200 was configure in switch.

  2. Ensure the switch ports that connected to Surf Soho and AP One AC Mini was configured as trunk port in switch.

AP One AC Mini

  1. Ensure Management Vlan on AP was Vlan 0.

  1. Ensure the IOT SSID was configured with Vlan 200

Hope this help.