Purchased USED SOHO have security concern

I recently purchased a USED Surf SOHO Mk3.

Does the Factory Reset via the Push Button perform a memory wipe and reload?

If not, is there a download that I can use to accomplish this?

Will re-flashing the current firmware accomplish this?

My thanks to everyone!

Noob!

Factory reset will wipe it and restore to original settings with whatever firmware in installed. Upgrading will not.

Having difficulty doing Factory reset. No matter how long I hold the button, the status LED will not blink red three times and the IO port leds only blink twice…

Advice?

Thanks

I’ve had similar issue with a used Balance 20.

Unplug all cables (wan,lan) and try a reset again.

You’re probably already familiar with @Michael234 website but if not

https://www.routersecurity.org/SurfSOHOinitialconfiguration.php

I pretty much followed it to setup my SOHO.

Alas, I have all cables unplugged. I have left off for over 30 minutes and tried again. Same result.
I opened a ticket.
Thanks

power off. Push and hold reset button. Power on - while still pushing in reset button. Wait 3 seconds, then release reset button.

Hello and thank you for the suggestion!

Unfortunately, the response is as follows:
Status LED turns SOLID red (not blinking 3 times), the LAN LEDs flash a couple of times then after about a minute the status turns green.

Nothing I do will cause the status LED to blink red THREE times as the manual says it should.

A thought: Am I reading the manual wrong? I read the manual as stating first the Status LED blinks TWO times and goes off during the password reset step and if the push button is still held,it will blink an additional THREE times.

Is it possible that during the Password Reset that the Status LED blinks TWO times ending in the OFF state and that it Turns ON once more and stays on for a while during the Factory Reset and THAT is considered the THIRD blink?

Thanks!
Jim

After doing your procedure, is the router going back to the default username, password, and IP addresses.

Do the following test: Change the admin password to something other than what it is now. make it unique (i.e. TQBFJOTLDB). Reboot the router and make sure that the new password is what we just used. If it is, then:

Do your hard reset as described above.

Is the password still TQBFJOTLDB? Or did it go back to admin/admin?

With a used Peplink router, you also need to be concerned with Incontrol2. If it was assigned to the seller’s account, you need to either disable Incontrol2 or somehow (no idea how) get it moved over to your account.

Factory reset, I would assume, is only concerned with “settings” and we can see the settings. We can’t see hacked firmware. So, while connected to another router, download the latest firmware from Peplink and manually install it. Then while running the firmware you downloaded, download the previous version of the firmware and install that. Now you are sure where both firmware copies came from.

When I do the hard reset the passwords change as well as the IP address so I think the Factory Reset is working. I have also created an Incontrol2 account with a VERY strong password and entered the serial number.

I also disabled Incontrol2 within the router.

I think all is good. If someone can confirm what really happens to the Status LED from the moment the reset button is pressed (starting with the LED being green) until the button is release in about 20+ seconds I would really appreciate it.

I suspect my issue is just how the 8.x firmware documentation explains the LED and it does not seem to match what my unit is doing.

Thanks

Jim