Problems upgrade SOTG firmware, cloudflare issue?


#1

Hi there, when I tried and update the firmware in the web control panel I get:
[TABLE=“class: cfg_tbl, width: 92%, align: center”]

[LEFT] [/LEFT]

             **Status**

             Firmware version**1.0.26**available for download.

[/TABLE]
[LEFT]
then when I click “Download and upgrade firmware” I get: “firmware verification failed”

[TABLE=“class: cfg_tbl, align: center”]

             Firmware verification failed.  Please try again.

[/TABLE]
[/LEFT]
When I tried and download from:

http://www.peplink.com/support/downloads/surf-firmware-and-user-manual-6-1-2/

I get a problem with Cloudflare:

     Error           1001           Ray ID: 24c1690e6ced04ce • 2015-11-27 22:53:38 UTC         DNS resolution error       
                                             What happened?             You've requested a page on a website (download.pepwave.com) that is on the [CloudFlare](https://www.cloudflare.com/5xx-error-landing?utm_source=error_100x)  network. CloudFlare is currently unable to resolve your requested  domain (download.pepwave.com). There are two potential causes of this:
  • Most likely:
    if the owner just signed up for CloudFlare it can take a few minutes for the website’s information to be distributed to our global network. - Less likely:
    something is wrong with this site’s configuration. Usually this happens when accounts have been signed up with a partner organization (e.g., a hosting provider) and the provider’s DNS fails.

thanks in advance if anyone can help.

cheers
Stu


#2

Hi Stu,

I was able to download. Please try this link - http://download.pepwave.com/firmware/sotg/fw-surfotg-1.0.26-1260.bin