Problems connecting Peplink30 to Adtran Advanta 3430


#1

Hi -

I am having trouble connecting my Peplink 30 to a Adtran Netvanta 3430. When I connect the 3430 to two different laptops or my NetGear router I get the full speed of my internet connection, 10Mbit up and 10MBbit down. When I connection it to my Peplink 30 I get various bad results, sometimes I get .5 Mbit down but 10 Mbit up, sometimes the opposite, sometime 4 Mbit down and 10 Mbit up, etc. Also, sometimes I get the WAN DNS health check failed message. I have tried many different cables, cross over cables, etc, different combinations of port speed settings, and have been unable to find any solution. I tried this on 5.3.12 and 5.4.6. I posted a related problem with not being able to change the port settings on 5.4.6 on a separate thread.

When I connect the 3430 to my NetGear router I see that it negotiates a port speed of 100Mbit Half. Could the Peplink 30 be having trouble with this kind of port connection? (Note I tried forcing the peplink port speed to this speed with no change).

One thing I have noticed is that the link LED on the 3430 is always green when connected to the peplink independent of the port speed I set it to. When the 3430 is connected to the NetGear router the link LED on the 3430 changes to orange. It looks like the peplink is not actually changing its port speeds…

Does anyone have any advice on how to handle this?

Thanks!
Brent


#2

Its the Adtran Netvanta 3430 not Advanta 3430. I will try putting small switch between the peplink30 and 3430 see if that makes a difference…


#3

I tried putting a switch between the peplink30 and 3430, no change, still seeing slow connection speeds.


#4

Please try to go to “http://<Your Peplink’s IP>/cgi-bin/MANGA/support.cgi” to change the speed and duplex with trigger on/off the Advertise Speed option. Please also check the current speed and duplex on Adtran as well.


#5

Thanks for the reply!

I have tried changing the Advertise Speed option, it does not seem to make a difference. I don’t have admin privileges on the 3430 so I can’t change the speed on that port without opening up a support ticket with my service provider. However, from what my other router is telling me, it negotiates to 100Mbit Half.

Brent


#6

When I try each DSL connection from just the modem to a computer or tablet, the connection is fine, and is as fast as it should be, and I have no problem connecting to any website.
Would anyone have any idea what I could be doing wrong with the Peplink settings? I am a newbie at configuring this sort of thing, and any ideas would be apprecaited.


#7

After locking down the port speed to 100 Mbps/Half Duplex, are you testing with a single WAN connection or are you load balancing with multiple WANs connected at the time? If you are not achieving the expected throughput for a single WAN, please open up a support ticket with us here so we may investigate the issue.


#8

Was this resolved? I know this thread is a year old, but I noticed the same thing on a Balance 20 using a Adtran 924e on TW Telecom. We were getting 35 down and 35 up with a laptop. In the Peplink 5 down and 35 up.


#9

Please open a support ticket and we will help you investigate the issue.