Problem with Verizon static IP accounts

I am having an issue with MAX-BR1 units not recognizing the APN for Verizon SIM cards if the account is set for static IP.

ABout half the time, the unit correctly picks up the APN as mw01.vzwstatic and comes right up. The other half the units do not, and someone has to log in locally, go to network->WAN->cellular and set the APN manually.

The problem with this is that I have a distributor drop shipping IP phones, POE switch, the Pepwave and the SIM cards to my customers. When the unit comes up on it’s own, the installation is just a physical install. But when it does not I have to walk the installer through making this change before I can get into the unit over cellular and get it set up for the primary Internet.

It also appears that on some units if you keep rebooting it it may pick up the APN after several attempts.

I am not sure if this is a Verizon problem or a Peplink problem.

Anyone else run into this?

Another customer has reported a similar issue but in that case the out of box settings always pick up the correct APN and his issue is that when he manually sets the APN it will not authenticate and provide the static IP. This is a very intermittent thing because it works just fine most of the time.

We will be looking into this issue on our end.

More information:
This problem continues, including on most recent firmware 6.2.2 built 1790
The unit eventually displays APN for the non-static IPs “verizoninternet”. I still have to set every one to custom and enter mw01.vzwstatic


Please open ticket for us to take closer look.

Thank you.