Problem with Pepwave Surf SOHO and Samsung Note 7


#1

I recently purchased a Samsung Note 7 and have been having the most peculiar issue with connectivity. I didn’t do any in-store setup, except the basic prompts and to make a phone call.

I am currently in a rural area with marginal (1 bar) of AT&T 4G. When I got home and started doing the phone setup, I noticed a very odd problem. Using the Note connected to WiFi on my Surf SOHO (which is connected to a Verizon hotspot), I was unable to get sign-ins working for Google. I kept getting connectivity warnings. “Can’t connect to server, try later”. Google Play Store - Connection timed out. However, I was able to surf the internet in Chrome, run a speedtest app, etc. Tried in airplane mode, and even with the SIM removed. Numerous factory resets, etc. Deleted data/cache for Play Store app. No dice.

At the same location, my other phone (S6 Active) is not having the same problem. Nor is my iPhone 6S Plus. Nor is any other device in my possession. Wen I am closer to town with LTE coverage, the phone works fine. Same story when it’s connected to other WiFi hotspots (including directly to my Verizon hotspot).

The AP is set at 802.11na. I can’t imagine what is causing this problem, but I seem to have ruled out everything except the router.

Posting this here in case anyone has seen this behavior. I did also create a support ticket.


#2

Weird. The SOHO will not treat your Note 7 any differently than any other device. Have you tried other AP’s besides the Verizon hotspot? Possible bad Wi-Fi in the Note 7?
We will try to help via the support ticket…
Thanks.


#3

I tried via another AP in a friend’s house and it worked fine.


#4

I have done some more research, and found that others (S7 and Note 5) have reported a similar problem in the past. The culprit seems to have been IPv6, and turning that off in their routers fixed the problem. It has also been worked around by an app called DNSet, which I am reluctant to use.

Here are a couple of links to discussions:

http://forums.cox.com/forum_home/internet_forum/f/5/t/13107.aspx

http://forums.androidcentral.com/samsung-galaxy-s7-edge/655209-galaxy-s7-can-t-download-apps-use-some-currently-installed-apps-over-wifi-why.html

So far, the only troubleshooting suggestion has been to use Google’s public DNS servers. I haven’t seen that make any difference. I disabled IPv6 in my Verizon router, which again did not change anything. I have learned that the Surf SOHO doesn’t support IPv6, so there are no settings to change.

I wish there a way to get more information from the SOHO, like detailed logging or packet level data that maybe could be useful to an engineer. Since I have another Samsung device that is working, maybe that would make some kind of comparison possible…?


#5

Hi,

Look like this is related to the S7 and Note 5 known issue for WIFI. Plenty issues reported if you search through internet.

Do you try before the solution given for the ATT forum thread below ?

https://forums.att.com/t5/Android/Samsung-Galaxy-S7-Edge-issues-with-WiFi/td-p/4768121 (Check on the last threads - Turn on LEGACY DHCP)

Thank You


#6

Yes. There is plenty of discussion if you dig. The links you shared seem to be related to poor performance. My specific issue is no connectivity at all for specific logins, apps. Nevertheless, it would not hurt for me to try that setting.

I got a response from Peplink support this morning to try setting the MTU to 1428 (default 1492). This solved my problem!


#7

BTW, enabling Legacy DHCP client killed all internet on my Note 7.


#8

I just read this morning that Samsung is recalling all Note 7’s because of a battery issue.