Problem with new OpenVPN Client Software

Using ExpressVPN. SOHO MK3.

I’ve installed the test firmware 8.1.0s024 build 4955, installed the license key and rebooted. I’ve entered in the username and password supplied by ExpressVPN (copy/paste so no typos) and uploaded the .opvn file provided by ExpressVPN. I’ve selected the appropriate WAN (5 GHz) and made it Priority 1.

I’ve tried OpenVPN 1 in as Priority 1, 2, and 3 but it is just staying as “Connecting…”

Alternatively, when I select “Disconnect” for Standby State for OpenVPN 1, it goes to “Cold Standby”.

Any ideas?

Probably start a ticket… seeing as its day-0 it might be a while before others gain enough experience to provide meaningful suggestions.

@tcpip95, we tested with ExpressVPN and it is working fine. Please help to open a ticket and attention to me. We wish to check what is happening there.

Thanks.

1 Like

Ticket opened #20090349. Thanks.

OK, I believe I have found the problem. For the VPN to work you MUST assign it to Priority 1 group. If it is not in Priority 1 group, it will go into Standby mode. Per the Guide, I had it in a lower Priority group. When I moved it up to Priority 1 group, it connected up.

I’m not sure that I actually have a VPN connection though. I am failing a DNS Leak Test, and it is still showing my Internet IP address.

UPDATE: Just spent two hours with ExpressVPN Tech Support. It appears that everything is configured properly on their end, so I’m guessing that this is a Day 0 problem.

For those of you playing along at home… :grinning:

I am getting a good VPN connection to my VPN provider. I’m getting assigned a 10.x.x.x address, default gateway, and DNS server.

I am seeing traffic flowing through the VPN tunnel (Status/Usage Reports/Real Time/OpenVPN interface). I’m downloading OpenSuse Leap DVD (4.33 GB) and both my WAN interface and the OpenVPN interface are showing the traffic.

However, when I do a DNS Leak Test, it still is showing my ISP-issued address publicly.

1 Like

Hmmm. Interesting. For some applications we would WANT to use OUR DNS. There are some other circumstances where using the VPN provider’s (i.e., to avoid the “leak.”) would be strongly advisable. Maybe a “switch” is needed.

Your clients are using the Peplink as their DNS it sounds like… if you set the clients behind your Peplink with the DNS server of your VPN provider does that all work as expected?

Also seems like maybe you have multiple WANs now within priority 1.

Can you move the other nonVPN WANs to priority 2 and still maintain OpenVPN connection? Doing that seems like it would ensure ALL traffic is routed over VPN.

On the DNS Proxy settings | Advanced Settings for DNS Resolvers - you should try setting the checkbox of your OpenVPN DNS wan as preferred.

@TK_Liew I’ve provided a series of updates to the ticket, but I’ve not gotten any updates from support. The problem appears to be down to a DNS leak. When you tested with ExpressVPN did you conduct the DNS Leak Test (https://www.expressvpn.com/dns-leak-test) to confirm complete compatibility?

@tcpip95, the technical support engineer who works with you is in a different timezone. You may let the support engineer knows what is your timezone and tell him you prefer the support engineer from the same timezone.

I saw you ask the same question in the ticket. Appreciate if you can help to follow up there.

Thanks.

1 Like

Many thanks to the Support team. They worked with me and were able to resolve the issues. I now have a solid Point-To-Point VPN connection to my VPN provider. Great job Support team!

1 Like

What was the resolution, please?

OK, here’s the resolution…

  1. Follow basic instructions as outlined in Quick Start Guide. Make sure your OpenVPN connection is in the same Priority 1 selection as your Primary Interface.

  2. Go to NETWORK/LAN/NETWORK SETTINGS.

  3. Under DNS PROXY SETTINGS, check ENABLE.

  4. Click on the Help (blue question mark), and then click on “Click here for the advanced settings in the DNS Resolvers selection”

    . Then select your OpenVPN interface (mine is labeled ExpressVPN).

  5. Go to ADVANCED/ADVANCED/OUTBOUND POLICY

  6. Add a new rule.

  7. Check Enable box, select OpenVPN (I labeled mine ExpressVPN), then choose When No Connections are Available. See options.

  8. Check to ensure traffic is flowing through the VPN tunnel, by going to STATUS/USAGE REPORTS/REAL TIME. Observe the traffic

I think that’s everything.

4 Likes

In addition to the 10-12 Mbps speed limitation, it is also pegging the CPU at a constant 100% at that speed.