Problem with DNS Proxy


#1

I have a Pepwave Max BR1 (firmware version 6.1.2) configured with the primary internet connection on the “WAN” port and the backup internet connection on the Max BR1 cellular connection. The primary “WAN” port is connected to a DSL router which in turn connects to the Internet. Internet connectivity works fine on both the primary and backup WAN connections, but DNS behavior is broken.

I have DNS proxy enabled as well as DHCP server with the option to “Assign DNS Server automatically” checked. The Pepwave’s LAN address is 192.168.5.1. As expected, the LAN connected clients get a DNS address of 192.168.5.1. However, they seem to be unable to reach a DNS server using this address. If I manually change a client’s DNS IP address to either the address of a known DNS server (such as Google 8.8.8.8) or the address of the DSL router attached to the “WAN” port (which is 192.168.1.1), then the DNS requests resolve fine and I get Internet connectivity. Note that the DSL router is also configured for DNS proxy which is why specifying its address allows the DNS requests to resolve.

Basically it appears that the DSL proxy is doing nothing even though enabled. Additional DNS settings are:
“Include Google Public DNS Servers” is checked
DNS resolvers: “WAN” port is checked, "Cellular port is checked
I have some local DNS records configured and they seem to work fine


#2

Hi Chris,

I suspect this is a known bug in v6.1.2. Please help to upgrade to v6.2.1.

Thank you.


#3

v6.2.1 seems to have solved the problem. Thanks.