Problem initialising 2nd wan connection

Hi I am struggling to get a Virgin Media Router in modem mode working as a wan connection on my Balance One it just keeps unsuccessfully trying to connect, appreciate if you could point me in the right direction. I disabled it as it wasn’t working. I did try to connect as a static ip but received a dns error


Hi donaldd,

Do you have a static IP address? If not, I wouldn’t recommend trying to enter a static IP address.

What version of firmware are you running on the Balance One? @MartinLangmaid has used multiple Virgin Media Routers in the past. So I would assume they would still work without issue. Can you try setting up a switch between the Virgin Media Router and the Balance One and see if that allows the WAN to connect?

It may also be worth reaching out to your Point Of Sale to see if they are able to assist you.

1 Like

It should be left as DHCP for sure.

What happens if you disable modem mode? Does it connect and work fine as typical a NAT router?

Do you have the Ethernet cable from the WAN of the Peplink into correct LAN port on the router - as it needs to be a specific LAN port when in modem mode?

Do try a different cable too.


Hi Martin, Toaster,

Thank you both for your replies, I have managed to resolve the problem, it would appear that when you put a Virgin Hub 3.0 into modem mode you have make sure to use the bottom port (4) and that it is the only socket used.
Once the Hub 3.0 has rebooted into modem mode you have to power it off again for at least 2 minutes, make sure your router is on first before powering it back up.


Hi donaldd,

Thanks for the update and for letting us know what the solution was. :smiley: