Problem in tests of Peplink MAX Adapter 5G.

Hi, thanks for your help and time reading this.

We made some 5G connectivity test but visible connectivity is not achieved (it does not appear connected to the 5g network). Not so, with the other networks (3G, LTE) which work without problems.

Browsing speed is tested in different LTE networks which, although it showed good results, it was not possible to appreciate any available or attainable network of the 5G type. We tried 2 SIM providers, with the same result. Tests are carried out in different designated 5G coverage areas, all of which are unsuccessful when searching for a 5G network.

At the begginning we thought that real coverage is not the same as the one indicated by the provider, but in 1 case navigation results were obtained above 200 Mbps (5g is was to confirmed or concluded). For this reason, it would be appreciated to confirm:

  1. Whether or not the device should be connected to a 5g network (via Peplink connection manager)? Is there a 5G indicator in the software?
  2. What is the 5G network test method that you recommend us to use?
  3. How can we force the connection to 5G, using the 5G adapter connection manager?

Thanks in advance,

Marco Bravo

Step one is doing a site survey to understand:

  1. What carriers cover the area
  2. What bands and technologies they are operating on (for 5G NSA vs. SA)
  3. Signal strengths
  4. Interference whether physical or radio wave, etc

Have you confirmed that you have usable 5g signal on the carrier for the SIM you have, that the Peplink device supports the band AND technology the carrier is using for 5G, and that there is good signal? Have you confirmed you are using the correct network connection parameters for the carrier?

What carrier and plan are you trying to use? Are you in the USA? Another country? Some more details would be good…

1 Like