Problem browsing some sites


#1

Hi

I have just setup a Balance 20 to two ISPs, both with dynamic IP. Everything seems to work fine except I have this really weird problem.

I have one of the LAN ports of the Balance 20 connected to the WAN port of an Apple Airport Extreme. I configured the Airport Extreme in Bridge Mode to serve as an Wireless Access Point. The problem is that when I am using a Mac or PC, I seem to have problems browsing to certain sites. It is just normal http URLs and the loading will just get stuck and nothing shows up. Browsing to the same site using an iPad is working fine. The Macs/PCs are connected to the same Airport Extreme wirelessly.

I have tried the following:

  1. Use different Macs and PCs
  2. Made sure the DNS server setting for iPad and Macs/PCs are the same. I have tried using Google DNS as well
  3. Connected the Macs/PCs to the LAN port of the Airport Extreme
  4. Set all HTTP traffic in Outbound Policy to Persistence and also Enforced
  5. Connect the Macs/PCs to a LTE MiFi (via a 4G mobile network) and those exact same sites can be reached without any problem. So the problem should not be with the PCs and Macs

The strange and frustrating thing is it only happens with a handful of sites. Browsing other sites have no problems at all

Any suggestions on what I can do or how to troubleshoot where the problem lies?

Thanks


#2

I solved it myself. One of the link’s MTU was set incorrectly. I had enabled Auto on both link’s settings and it was detected at 1492 for both. When I set the WAN1 MTU to default of 1440, then all the problems went away. I am not sure why as I had previously set all http traffic to go out via WAN2 only but it still did not work then. And does not explain why it worked fine for the iPad but not the PCs/Macs.

Anyway, as long as it works now.