PrimeCare Unlimited FusionHub Licenses


I see as part of PrimeCare you advertise “Unlimited FusionHub Licenses” (…how do we go about obtaining these License’s?

Also, we have a load of Balance 20X’s (on Primecare)…but also a few Surf Soho’s, what FusionHub licence do I need?

Many Thanks


Hi MIck,

According to the webpage, PrimeCare devices will not count towards the peer limit of any FusionHub.
You should therefor be able to download a Fusionhub solo and connect as many peers as you like.
There are no bandwidth restrictions. Although you 'd probably need to add more resources to your VM depending on the amount of peers.

See the FAQ and requirements at the bottom of this page for information on where you can download the licenses.

We often choose to add more Fusionhub VMs instead of adding peers to the same Fusionhub.

Hope that helps,



Thanks Erik…that makes sense now, and I can confirm it works!


That is good to know, thanks Mick!

1 Like

So something that’s become apparent with using a FusionHub Solo with “Primecare” devices…

It would seem that if you select a “Star” VPN configuration from Incontrol including a load of “Primecare” devices, and the FusionHub Solo as the Hub…the routes never start successfully.

If I add them as individual point to point…they connect fine.

Is this a restriction of the Fusion Hub Solo? If so, then I think there perhaps needs to be a “special” Primecare licence for FusionHub

Many thanks



@mickbeaumont, may I know how many end point devices you added when you configure the Star topology? All the end point devices are Primecare devices?

May I know how many point to point profile you configured for the FusionHub Solo?

Please try this firmware for FusionHub Solo to confirm it helps -

1 Like

Initially I tried 4 x Primecare Devices (Balance 20X), and 1 normal (Surf Soho), in a Star with the FusionHub Solo as the Hub… that didn’t work.
Then I tried just the 4 x Primecare Devices…that didn’t work either.

Applying all these as point to point worked fine (currently have 5 x Point to Point’s with same devices working)

So I’ve updated the Firmware to the one you suggested, and interestingly now it doesn’t appear in the list of “Hub” devices when I try to create a hub…(that is with removing all the point to point links I’ve created previously)

…so cant really confirm it that helps…(I would suggest not!)

Many thanks


(I have a workaround using point to point…but its just a bit annoying!)