Preventing router attached to LAN port from serving DHCP to other devices on other lan ports of B30


#1

I have a peplink balance 30, firmware 5.4.9 build 1732. Attached to the 4 LAN ports are 3 devices, plus another router. The router is actually in another room of the house, connected by an ethernet over powerline adapter, if that matters.

So

Two wans <–> Peplink balance 30 <—> Ethernet over powerline ----powerline----Ethernet over powerline <----> Another router

The peplink has IP 192.168.3.1 as gateway. The router “Another router” has 192.168.1.1 as its gateway address.

Occasionally, the 3 devices attached to the balance 30 stop using their assigned 192.168.3.x IP address and suddenly acquire a 192.168.1.x address. I guess this is at time of lease renewal because it happens to all of them at the same time.

This results in loss of internet connectivity.

I solve this problem by disconnecting the powerline adapter from the peplink, then release/renew IP of the other devices. They then go back to 192.168.3.x as usual. If I just release/renew without disconnecting the powerline, they just get another 192.168.1.x address. @_@

Anyone have any idea why that router is serving DHCP to these other devices, and how to stop that?

Thanks

J


#2

Hello Jack,
Do you mean your LAN have 2 gateways? Peplink at 192.168.3.1 and your router at 192.168.1.1? If you are not implementing VLANs on your network, there shouldn’t be 2 different broadcast domains.
From how I see here, you should disable DHCP on your 192.168.1.1 router. This way, all of your devices will grab IP from Peplink only.

Cheers.


#3

Hi thanks Florence. The 192.168.1.1 router needs DHCP on because it services a room in the house that is not accessible to the main peplink device. There are several devices in that room that get internet connectivity through that router. 99% of the time, that router just respects its proper place and serves DHCP to devices that are connected to it in that room. What I want to block is it servicing DHCP backwards through the peplink to devices hooked up directly to the peplink. I was wondering if maybe I could block some ports within the peplink from communicating with the device. To prevent traffic to/from the device that would block dhcp from coming from that device through the peplink.

Or do you mean I could disable DHCP on the 192.168.1.1 device, and turn the router into a bridge and the devices could get IP addresses from the peplink? Would that work over wifi through that device?


#4

DHCP works at a lower level than IP addressing - there are no ports to block. Are you saying that room 2 (x.1.1 net), is connected to the peplink as a lan client with a 3.x address? Or has its own gateway to some other internet source, and the dhcp problem is noise that leaks across the common powerline aspect?


#5

Yup the x.1.1 router is a client of the peplink with a .3.x address, correct. There are 2 WAN lines in the house, both going into the peplink. The peplink serves DHCP to a few computers in the same room as the peplink. Then there is a router in a remote room of the house, that is connected to a LAN port on the peplink, using a powerline adapter. Most of the time everything works ok. The 192.168.1.1 router gets a 192.168.3.x address from the peplink, then in turn provides internet connectivity to several devices in the other room.

Just occasionally, for some reason/somehow, the devices in the same room as the peplink suddenly start getting their IP address from the 192.168.1.1 router. I know this is the case because if I release/renew IP addresses, they stay 192.168.1.x. There is no internet connectivity. But if I disconnect the powerline adapter, essentially breaking the connection to the other router, then release & renew, everything gets 192.168.3.x addresses as usual and every device is happy again.


#6

It definitely sounds like your powerline adapter is the source of your problem and the fix is easy.

From what I can tell, you have some devices in that other room that need Ethernet connectivity so you hooked up a new router there for this purpose and technically they don’t need to be on a different subnet. This device should actually be just a dumb switch and not operating as a router.

You just need to reconfigure it by disabling DHCP, assigning a 192.168.3.x address to the the LAN, and then connect the powerline adapter to a LAN port instead of the WAN port. This will also retain wireless connectivity if it is serving up Wi-Fi as well.

This way all devices in your house will receive DHCP from the Peplink.


#7

Great! Thanks I will try that.