Powers on, can't login via IP

I powered up my peplink Max br1 MK2 the lights come on and when I connect to the router using the landport I can’t get to the log on page via

Nothing happens at all. Am I missing something?

Is this a new device out of the box or one that has been in use?

What IP address do you get when you connect to the LAN? Is it something like
If so, did you check to see if works?

1 Like

It is not new. I bought it from a police auction. The Verizon store said it was available using their IME number (did I get that wrong?) anyways, I just bought a SIM for it in case that was preventing me from getting to a login screen…

I went to computer tech store to see if they could log in with their laptop and they could not but he did pick up using the command console that it was registering at 192.168. 50. 1 but like I said he was not able to bring up anything when attempting to log into that IP address and neither can I now that I have gotten the SIM card inserted an activated it’s still not working.

I’m beginning to think that somehow this device is kaput because the company doesn’t allow for devices to be bought and used from a second hand sale, which sucks. Capitalism I guess. IDK

There is a hardware reset button on the front of the MAX BR1 - a tiny hole you need to push a paperclip into to reset it. If you power it up and then press and hold the reset button in for a 20 count it shoudl reboot with default factory settings and show a web interface at

The tiny hole!!! I entered the tiny hole and it worked!! There is life!!