Port Settings for Xbox One

Hello,

I am currently running the Pepwave MK2 and am having trouble with online gaming. I am unable to change the NAT type from ‘Strict’ to ‘Open’ on the Xbox. I have forwarded the ports as seen in the screenshot below, but it seems that was not enough to change the NAT type.


Any advice would be much appreciated.

Hi Jack, welcome to the community!

Is your WAN Interface IP a public one?

Thanks

Thanks for the welcome!

How would I go about checking that? Sorry I am a novice when it comes to this.

Hi Jack,

Hit the website ipchicken.com It will tell you what the internet sees your IP as. Then compare it to the one you see on your Peplink dashboard. If they are the same, then you have a public IP and it’s just a matter of changing settings. If they are different, then it becomes very complicated.

As a note, I’m a fellow Xbox gamer and you can achieve open nat now with just port 3074 UDP, nothing else is needed anymore :-). I had all those same rules in my peplink for 4 months and had logging turned on… only one port is used now. The change appears to have been made in 2017 so you can have multiple Xboxes in one household.

Have you tried fully restarting the Xbox after applying the port forwards? I spent literally hours on this only to discover the Xbox One is weird and had to be fully powered down (hold down the power button till it turns off all the way) and then powered back up. As soon as I did that it showed Open NAT. Super annoying.

Unfortunately, the IP showing up through the link you provided is not the same as what my Pepwave Dashboard is showing. Is there a way to change it to a public IP? Hopefully not all hope is lost.
I also tried fully powering down the Xbox with no luck.

What kind of internet service do you have?

What Peplink product are you using and is SpeedFusion to a FusionHub a possibility? I don’t have a public IP, so I host a FusionHub instance at Vultr in Dallas, then use their public IP to forward traffic back to my Peplink Max Transit at the house. If you lookup Peplink Ninja, he has great tutorials on how to setup a FusionHub.

https://peplink.ninja/2020/05/02/how-to-setup-peplink-fusionhub-on-vultr-com/

I am using a PepWave Mk2 utilizing an AT&T unlimited data plan. Looking at the router dashboard, there is a tab specifically for SpeedFusion Cloud. Will this be my only option?

An AT&T unlimited plan

So this is a cellular plan then? You will need to subscribe to a static public IP if they offer it as an option.

Yes this is a cellular plan. So there is no way to do it through the router? It looks like there are some static IP options within the Admin Dashboard.

AT&T offers strict NAT (out of the box)
T-Mobile gives you Moderate NAT
I don’t have personal experience with other carriers.

SpeedFusion cloud doesn’t support inbound traffic, so that’s not an option. The MK2 appears to offer the basic SpeedFusion hot failover. That would work for connecting to a FusionHub. Getting the FusionHub setup in the cloud isn’t hard, but can be daunting at first. Vultr runs $5 a month, so once it’s running it’s a pretty cheap solution, but it’s not as point and click friendly as say digital ocean or AWS marketplace.

One other downside is Netflix and Hulu, etc., generally won’t work through a VPS.

A slight modification: Netflix et al. keep track of public VPN hubs and tend to block them. If you have a VPN connection to a (say) corporate hub then they seem not to care. So the key element is not the VPN, but rather the VPN-provider.

1 Like

Thank you everyone for your help! Looks like I’ll go with trying the FusionHub option.

Thanks again!

@Kenny posted the RAW image for FW 8.1.0 just now. It works on UpCloud (and presumably Vultr): FusionHub 8.1.0 RAW image.

Installed nicely on an ubuntu-1cpu-1gb-us-sjo1 based instance with 25GB storage (the installation process sheds the Ubuntu along the way).

Cheers,

Z