Port Settings for Playstation


#1

Hello,

I recently purchased a Balance One Core and I am trying to get it setup in my home. I was able to use the Outbound Policy for setting up with Playstation however from the thread titled (Port Settings for Microsoft Xbox Live) however on the inbound access there is no ability to “Add Server” so I am kind of stopped in my tracks. Do I even need to setup an inbound policy? I’m guessing yes but I am not sure how to move forward to finish the setup. I searched the forums and was unable to find another solution dealing with Playstation.

The ports are:

TCP Ports UDP Ports
80, 443, 1935, 3478-3480 3478-3479

Can anyone please help me out.

Thank you in advance!

Matt


#2

You may want to refer to this KB article.

Let us know if you need further assistance.


#3

Just add in the require ports in Inbound Access --> Port Forwarding and this should give you the inbound access


#4

I had already read through the KB article and I understand the top half of the above example. I assume I would place a check in all connections because the playstation would be sending and receiving data from all.

I am not sure what to do with the Server IP Address field. Playstation doesn’t offer a IP address to their servers per-say they only give ports to be opened. So what would I place in the Server IP Address field? OR is the “server” considered the IP address of the my PS4?

Thanks in advance and Merry Christmas!

Matt


#5

Easiest way to do what you want is to assign a reservation in DHCP for the Xbox and PlayStation. Next, allow UPnP and NAT-PMP. Finally, allow all inbound traffic to the reserved IPs via the inbound firewall rules.

UPnP will request the appropriate port forwarders from the router. The firewall is set to allow the traffic. Botta boom botta bing - you be gaming.

This method is more secure and much easier. Your game consoles really only use one or two ports at a time for inbound traffic.

Hope this helps. Merry Christmas and enjoy the router. You will be happy you got it.


#6

Yes, server IP considered the IP address of your PS4 or in other word, services/devices IP that need to access by public.

@jmjones is right, you can use “UPnP” to automated inbound access.

Make sure UPnP is supported & turned on for your Xbox live device as well


#7

OK so this is what I have:

Does this look correct?

Thanks for the help!

Matt


#8

The given settings look fine. For the UPnP/NAT-PMP settings, if you manually managing the inbound access then you can disable the options.

Do further test on the Xbox live connections and if the connections work fine than that should be the rules that you need.


#9

You really should restrict the console to a single link. The consoles start to do weird crap when you split the IP traffic down multiple paths.

It looks like you assigned a static IP of 192.168.1.15 to your PlayStation. Good. We are gonna use that for the example configs

Not to be a jerk, but it really is better to let UPNP do its job. Personally, I would delete the manual forwarders that you have created. Since you are going to limit the outbound traffic to one WAN link, all the inbound stuff will come in that WAN link.

Here we go.
First - assign static IP (check)

Second - limit the outbound traffic to the WAN link with the quickest response time. Latency is key with online gaming. Whichever gives you the best ping response to sites on the internet is the pony you want to pick. Do this by going to Network->Outbound policy. put in a new rule named PS4_WAN1 and put in the source IP of 192.168.1.15 and choose “Enforced” as your balance algorithm. Choose WAN1 as the link. The destination should be ALL and the port number should be ALL and the port type will be BOTH.

Third - Open the firewall up to 192.168.1.15. Do this by going to Network->Access Rules (underneath Firewall). Add a new rule named PS4_OPEN. The source will be ANY, the Destination will be the IP Address 192.168.1.15. Protocol will be BOTH. Port number will be ANY. It is your choice as to whether you allow it for All Wan links, but make sure that the WAN you are sending the outbound traffic to is included. I like to enable logging for all of my inbound rules.

Fourth - clear the NAT-PMP and UPnP state. Go to Status->NAT-PMP. This area is what you don’t get access to with most commercial routers for home use. Delete anything that you might have there by hitting the red X. Don’t worry, everything will recreate itself.

Fifth - Completely shut down the PS4. unplug it from the wall for a minute.

Sixth (optional) - if you are like me, you have probably done it on your own and tried 1000 different combinations. Restart the router if you can.

Seventh - once the WAN links are established again, start up the PS4. Confirm the UPnP and NAT-PMP settings by looking at the status page of the router (you are going to fall in love with this page).

Eighth - (optional, but highly advised) Route ALL other traffic elsewhere. Right underneath your Outbound Policy rule (the one that keeps all the PS4 connections to 1 WAN), create another rule named “non-games”. Set the source IP to ANY. Set the Destination IP to ANY. Protocol type of ANY. Set the algorithm to Overflow (since you have three other WAN links) and make the last one in the list be the WAN you dedicated for gaming. You will notice there is a “Enabled” checkbox. Turn it on while gaming and then disable it when you are done.

At the end of it, you should have an Open NAT type that is dynamic in nature (you won’t need to add new forwarders when a new game or feature is released by PS4), a dedicated WAN link just for the PS4, and a hella smile since you have got it all sorted.

I am invested now, so please let me know how it works out.


#10

Well I started making all the above changes in the settings suggested (thank you for taking the time to type all of that). But after making the changes, and rebooting everything about an hour later all heck broke loose. DNS failures on WAN’s across the board. Everything stopped working, I can’t even connect directly to the modem I get a DNS failure on all modems. So I panicked and un-did everything thinking something I had just entered had messed up the system but it didn’t matter.

So now I am down to using the one modem that I could not fit on the Balance One (only 5 WAN ports) and all the modems are unusable. I called Frontier and scheduled a tech to come out. Apparently due to an impending firmware upgrade you can’t use the reset button on the Netgear 7550 or the D2200D modems or they will not be upgradeable so I have to wait for them to bring new modems…

Man this has been a rough install…

I do have one question about the above, on the third step the new access rules will be an incomming rule correct not an outbound rule?

Thanks again for all of your help.

Matt


#11

Bummer. Sorry if any of my instructions caused you to brick your modems. I don’t see how, since none of the steps touched any WAN configs. I wonder if you reverted to previous software accidentally when you rebooted. You can check by going into the reboot router page and checking which firmware is running and what is in the other slot. I would imagine you want the newest firmware. Have you tried each modem connected directly to a PC? Those things are rubbish if they are really bricked - nothing you did should have caused that - unless you dunked them in water or something.

I always use the ping health monitor and ping the gateway. I figured it would give me a more reliable indication of the link health. DNS has more potential failure points

Step 3 is an inbound firewall rule. Step 2 is an outbound policy. Step 2 limits the PS4 to one WAN only. Many of the games and services issue tokens that may be tied to an IP. The game servers and matchmaking algorithms don’t work well with multiple IPs coming in for a single console. Step 3 allows the port forwarders established by UPnP to function (pass the data from the wan to the LAN)


#12

I don’t think the instructions bricked the modems, they were all working
for at least an hour then started dropping off. I was running the latest
firmware. I am almost wondering if it isn’t some kind of result from
changing them all to bridge/routed bridge.

I guess I will see what the Frontier tech says happened.

Matt


#13

I am reading through the other forum posts on this WAN failed DNS test, seems to be a common issue with Peplink. I wish Peplink had some kind of phone support. I just started having WAN failed DNS test issues on my last modem where I couldn’t even connect to the internet. I removed the Balance One and the issue went away. I am pretty confident the Balance One caused the problem I just don’t know why yet.

Matt


#14

Did you change them from router bridge to bridge OR was it the other way around?

It may just be as simple as filling out the WAN connection properties to match what the modem was doing. Or even simpler, just a matter of assigning the public IP to the WAN. I would think that an ISP would be able to walk you through that over the phone.

Tell me more about your WAN configurations before the modem incident.

Oh, and I assume you changed the setting on all 4 modems prior to checking that it worked, didn’t ya? I have also learned that lesson. I applied some new drivers to three nodes of a cluster at the same time. Blue screened them all. Had to drive into the office to boot from CD. Luckily, it is a lesson you only need to learn once.

I am going to see if I can find any specifics for the hardware you have and post back.


#15

@matt_stock I just checked a video on that router and frontiers service. It looks to me that if the modems are in bridge mode, you need to change you WAN settings so that it uses PPP authentication. It looks like you use your frontier.com email address as the username. You will have to get all the connection details from them if you don’t already have it.

By going to bridge mode, you moved the connection authentication from the modem to the next device down (peplink or PC).

If you want, send me a message with your contact info and a good time to work on it and I will try to walk you through it over the phone.

The Peplink router is going to be awesome for you and I hate that you are having issues getting it up and running. It is hard to gauge computer literacy in a forum, so I apologize in advance if I speak over or under your proficiency level.


#16

@matt_stock

Found that you have open a support ticket for the issue. Support team will follow with you using the support ticket.


#17

Sorry for the delay in getting back to you still managing the holiday’s between family members.

So, I was able to get Frontier here which was shocking because it normally takes them a week to think about doing anything. Maybe it was my anger with the situation that motivated them… :confused:

Anyway the gentleman that came out was (IMO) A++ tech! First time I have had someone come out who seemed interested in their job. He understood what I was trying to do and was even somewhat familiar with a few of the Peplink products. So what he did was change my setup from a bridge/routed bridge setup to a bridge/bridge setup. So the modems are producing a raw IP address not the managed 192.168.#.#. He also changed my DNS servers to 8.8.8.8 and 8.8.4.4.

So the Peplink now has total control of the system. As of right now I appear to only be having a WAN issue with one modem (this was an an issue from a different thread where all the modems were failing DNS tests).

Now that the configuration of the bridge changed is the method for managing the ports for the PlayStations you laid out above still the best way to do it? I am assuming it is but is doesn’t hurt to ask.

In addition, I just spoke to to a Frontier CS agent and got all of my PPoE info (user/PW) so I have this available if needed.

Matt


#18

Indeed it is. All of the steps were changing your LAN setup and ability to do automated WAN forwarding. Good luck to you sir! Glad he got you going.


#19

Thank you jmjones, without your help I would still be spinning my wheels on understanding how the port forwarding should be managed between PS4’s. I hope if someone else out there winds up in the same situation the simple steps you laid out for me will help them with their setup.

Thanks again and have a Happy New Year!

Matt


#20

Great news. Glad it is working for you.

You can do the same thing for xboxes or additional consoles that you might have. Choose a different WAN link for each console for the lowest latency possible.

Those consoles are pretty clever, they can figure out if a port they want is in use - then they change the WAN port and map it to the LAN port with contention. It is really neat how it works.

Happy New Year!
I just upgrade from a balance 30 to the balance one. My main reason was for more LAN ports and the gigabit link speeds. Now, if only I could get faster internet connections…