Plex not accessible outside LAN


#1

New Surf Soho user here. Very happy with the reliability of the wireless connections, but having some trouble with both Plex and my Denon HEOS audio system (will post about HEOS in a separate thread).

On Plex, I’ve turned on both UPnP and NAT-PMP but I still cannot access Plex outside my LAN.

Thoughts?


#2

You could try opening port 32400 (TCP) on your WAN and forwarding to your Plex Server.


#3

I tried this but I am still getting the message “not available outside your network” in Plex.

Is there something else I need to do on the SoHo admin console?


#4

Do you have a public IP on the WAN of the surf SOHO or is is a private IP assigned from another router?

Thinking you might have double NAT going on and need to forward the port on your ISP router to the SOHO then on to the plex server.


#5

As Martin has said, sound like double NAT.
On the main dashboard of your Pep, what is the WAN IP address? (Only post the first two groups of numbers e.g. 192.168.xx.xxx)
If it is something like 192.168.1.10 or 172.16.126, it is double NAT in which case you would also need to port forward on you internet providers router which is not optimal.
Best option is to set your providers router to “bridge mode” or “dumb mode” which allows the public IP address to be forwarded to the Pepwave.


#7

Under “WAN Status”, my IP Address is 82.8.XXX.XX


#8

Sounds like you have a public IP address assigned to your Pep.
Can you provide a screenshot of your port forwarding rules?w


#9

In Advanced / Port Forwarding, the only things on the page are ticked boxes for NAT-PMP and UPnP.


#10

I just installed Plex server to try this. Intentionally disabled UPNP NAT-PMP because I don’t like it, and forwarded port 32400 through from WAN to LAN IP.

Didn’t work. Tried a manual port of 32401 didn’t work. Lowered manual public port to 444 as a test and it did work.

Then I came back to the screen again about 30mins later and it had stopped working again.
Playing a hunch, I tried a different laptop and it said that Plex was fully accessible outside of the network - green light.

I think Plex server is a bit crap at coping with port changes in general - that it takes a few attempts to connect on a new port before it will work, and that the web UI has browser session dependencies that screw with you when you’re fault finding.


#11

Thanks. Tried this but it didn’t work either.

Thoughts on why UPnP/NAT-PMP are not working? I understand there are security concerns around using these and would prefer to manually specify the port, but since that is not working not sure what my options are?


#12

It worked immediately for me with UPnP/NAT-PMP enabled with default Plex port, but I turned it off as I hate running those services - far too risky.

I’m running a Balance 580, but to my knowledge there have been no firmware changes to these services in ages.

With your port open can http://www.canyouseeme.org/ see it?