Ping ICMP echo on Mk3 surf

I can’t seem to block the ping request on my MK3 Surf SOHO, I have selected No on the ICMP box on each of the 2.4 and 5GHz (accessible via the dashboard). The surf replaced my ISP router. The ISP router passed the shields up ICMP test but can’t get the surf to do the same. Any help is greatly appreciated.

Hi - Welcome to the forum!
Where are you disabling it?
If you want to disable ping from the WAN you’ll want to be in WAN settings

1 Like

That did it! I don’t know how I missed that.
Thank You. I am very grateful!

I very much enjoy all the features of this router.

2 Likes