Pepwave Surf SOHO CLI SSH not working


#1

Despite the documentation says username/password for SSH is the same as those for web access, using my non default admin username fails to login via SSH. When I use the default admin username to login, I received “sh: /usr/local/ilink/bin/clish: not found” after entering the correct password then connection is closed. Is this a known issue? Using firmware 6.3.0s018 build 1989.


#2

Please open a support ticket for further investigation:
https://contact.peplink.com/secure/create-support-ticket.html


#3

What was the solution for this problem? I have the same issue. Trying to ssh in and getting an authentication failed. Instead of telling people to open tickets, why not post the solution here? Shouldn’t have to be a country club member to get fixes. We all paid for these GD routers. Just post the solutions when people ask for them.


#4

I solved my issue. If you change the “admin” username in the router settings, you will not be able to SSH in. In order to SSH you have to keep “admin” as the username. You’ll have to ssh admin@<router_ip>. This can’t be lamer. I can change the admin username from the default and use the web interface, but the CLI expects admin as a username. So lame! Fix it guys. This kind of shoddy configuration doesn’t inspire when it comes to security features of this router.


#5

Thanks for reporting this. We will look into this.