Pepwave Surf on-the-go and inControl

I cannot get my SurfOnTheGo registered with InControl. I understand the the SOTG isn’t yet supported by inControl2.
The error is that the device has already been registered.

This is a brand new router. Is anyone else having this issue?


Hi Greg,

Can you PM the serial number to me?


1 Like

What was the solution to this problem. I am having the same issue. My understanding my SOTG is not supported under InControl2 and Incontrol1 says device is already registered or invalid serial number.

@brettjeepski, can you PM your serial number? I need to check with the related team.

1 Like

I can’t for the life of me find a way to PM? I click on you profile and I don’t see an option to do it?

@brettjeepski, here you go.

1 Like

Is there a resolution to this ? I have the same problem: I have a SURF OTG, with the latest firmware, and cannot see how to enable incontrol2 for it.

Peplink support !!!

when are we going to get an answer to this ???

Hello Everyone,

We apologize for the delay on posting this as a download.

Here is a link to download the 1.1.1 beta 8. This has been stable for the couple of customers we’ve provided it to and on the devices we’ve been testing in the office, but we are still testing to make sure that this build is ready for GA.


1 Like

Hi all,

With the Firmware provided by Zach above, you’ll need to make sure that InControl management has been enabled:-

From the Dashboard, click the Settings button:-

Then click on the System tab, on the top menu and then select InControl from the menu on the left. Make sure the “Enable” box is ticked.

Save the settings.

Then you will be able to add the Surf-on-the-Go to the appropriate group on InControl.

Hope this helps,


1 Like