Pepwave MAX Transit - Spectrum eu2251 Modem - limited to 100mb/s

I have an issue and have had my modem replaced and still have the same issue with the wan connection limited to 100mbps. I have also tried to manually change this on the support page to 1000 but I cannot get a connection to the modem. Any thoughts?

Pepwave MAX Transit
Spectrum - EU 2251 modem

Assuming they are directly connected it’s very likely a dodgy cable between them. swap it out.


They were out today, replaced the modem,‘I’ve used several cables and also get 300 max direct with a laptop. So not it unfortunately.

Put a cheap unmanaged switch between them, I’ve solved autonegotiation issues that way on more than a few occasions.

1 Like

So I bought another modem and same issue. Maybe something is wrong with my WAN port and it’s defaulting to 100? Is there an easy way to change out the jack on it?

I think that would be very unlikely.

Do the pins all look good?

Have you tried it in to another device, maybe just a normal switch?

1 Like

So I have done the following.

The pins do look good.

I have had spectrum replace the modem, I have bought a aries SB8200 modem and swapped it out, same issue. I have now added a 1gig switch between modem and wan port of my max transit and still is showing 100 mbps speed in auto. When swapped to 1GIG it wont connect. I have also tried to lower the firmware all the way to 8.2 with the same issue…

@katson01, you may submit a ticket for our team to look at the device.

You may quote this forum thread so the team is aware of the background of the case.

1 Like